[GE users] SGE 6.2u5: save_sge_config.sh and load_sge_config.sh

wlee_hess wlee at hess.com
Thu Oct 21 19:30:56 BST 2010


To all,

I've managed to use the method listed in the web link below to back up our SGE 6.2u5 configuration to a Subversion repository using a combination of the save_sge_config.sh and the Subversion svn_load_dirs.pl scripts.

http://scompt.com/blog/archives/2009/10/13/versioned-grid-engine-configuration

I have a few questions with regards to recovering a previous configuration from my repository.

1. What I am wondering is if anyone has attempted to roll back their SGE configuration to a previous configuration using the "load_sge_config.sh" script?  If so, is it as simple as checking out a version of the configuration from the Subversion repository, then pointing the "load_sge_config.sh" script to the checked out version and letting the "load_sge_configs.sh" reload/reinstall the previous configuration into SGE?

2. If I can perform a roll back, can I do this while the SGE Qmaster server processes are running or does it make sense to shutdown the Qmaster server processes, do the roll back, and then restart the Qmaster?

Thanks in advance.

NOTE: For those of you employing Ed Dale's Subversion backup/versioning, I had to use a later release of the "svn_load_dirs.pl" script since version 1.4.2 of the script doesn't seem to handle the SGE hostgroup files I've created properly.  This is because their names start with an "@" (i.e. at) character.  I managed to update the script with Subversion 1.6.6's script which does not have this problem.

Regards,

Wayne

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=288941

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list