[GE issues] [Issue 3288] New - load/save_sge_config.sh's "usage" output in one line only

reuti reuti at staff.uni-marburg.de
Sun Oct 24 13:56:23 BST 2010


http://gridengine.sunsource.net/issues/show_bug.cgi?id=3288
                 Issue #|3288
                 Summary|load/save_sge_config.sh's "usage" output in one line o
                        |nly
               Component|gridengine
                 Version|6.2u5
                Platform|All
                     URL|
              OS/Version|All
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|clients
             Assigned to|roland
             Reported by|reuti






------- Additional comments from reuti at sunsource.net Sun Oct 24 05:56:22 -0700 2010 -------
The scripts "load/save_sge_config.sh" use one `echo` command to display its usage. The default under Linux's `echo` is not to interpret the
escape sequences and will result in one long line only, although the intention was to have it printed out on several ones. This might be
different on other platforms though. Snippet to get the correct behavior would be to add a "-e" to allow that escape sequences will be
honored (works with the plain /bin/echo or bash's builtin):

INFOTEXT=echo
nonewline=`$INFOTEXT "\n"`
if [ "$nonewline" == "\n" ]; then
    INFOTEXT="echo -e"
fi

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=36&dsMessageId=289683

To unsubscribe from this discussion, e-mail: [issues-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list