[GE users] SGE failed to compile: undefined reference to sge_gdi2_send_any_request

reuti reuti at staff.uni-marburg.de
Wed Oct 27 20:53:59 BST 2010


Am 27.10.2010 um 21:27 schrieb jdm64 <jdm64 at csu.fullerton.edu>:

> I don't have the exact error message with me right now but the  
> general error was that the gethostname binary in the utils folder  
> could not be run.
>
> running 'file' on it showed that it was a 64bit elf binary. Then I  
> tried to see if it was linking using 'ldd'. But ldd crashed saying  
> it couldn't find the file! I tried all path methods (and checked I  
> got the path right with ls) I could think of, but ldd kept crashing.  
> I got the same error trying to run the binary directly.
>
> I also ran 'chmod +x' on the file.

I saw such output when there is a wrong version of a library in your  
LD_LIBRARY_PATH Is it empty or set?

You can also try:

$ readelf -a gethostname

'ldd' is working for the usual applications like 'ls'?

-- Reuti


> Justin Madru
>
>> Hi,
>>
>> Am 25.10.2010 um 22:17 schrieb jdm64 <jdm64 at csu.fullerton.edu>:
>>
>>> I'm trying to compile the CVS source for SGE6.2u5 (mainly because  
>>> the
>>> provided binaries fail to install with ArchLinux x64).
>>
>> what kind of error did you get during installation? Maybe this can
>> easily be fixed and avoid the recompilation.
>>
>> -- Reuti
>>
>>
>>> But I get the
>>> following compiler error.
>>>
>>> _________C_O_R_E__S_Y_S_T_E_M_____________
>>> gcc -o test_performance
>>> -L/off_home/gridengine/db-4.4.20/lx26-amd64/lib/ -L. -rdynamic
>>> -Wl,-rpath,\$ORIGIN/../../lib/lx26-amd64
>>> -L/off_home/gridengine/openssl-0.9.8h-origin/lx26-amd64/lib
>>> test_performance.o sig_handlers.o -lspoolloader -lspoolb -lspool - 
>>> ldb
>>> libspool.so libsgeobj.so libsgeobjd.so libsched.so liblck.so
>>> libcull.so libcomm.so libcommlists.so libuti.so librmon.so  -ldl
>>> -ljemalloc /home/user/gridengine/source/3rdparty/plpa/plpa-1.3.1/
>>> LINUXAMD64_26/src/libplpa/.libs/libplpa.a
>>> -lm -lpthread
>>> /usr/bin/ld: warning: libgdi.so, needed by libsched.so, not found  
>>> (try
>>> using -rpath or -rpath-link)
>>> libsgeobj.so: undefined reference to `sge_gdi2_send_any_request'
>>> libsched.so: undefined reference to `sge_gdi_extract_answer'
>>> collect2: ld returned 1 exit status
>>> make: *** [test_performance] Error 1
>>> not done
>>>
>>> Justin Madru
>>>
>>> ------------------------------------------------------
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=290029
>>>
>>> To unsubscribe from this discussion, e-mail: [users-
>>> unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=290555

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list