[GE users] Multithread

seandavi seandavi at gmail.com
Fri Oct 29 11:58:21 BST 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]



On Fri, Oct 29, 2010 at 6:20 AM, lobosky <mauro.donadello at ifom-ieo-campus.it<mailto:mauro.donadello at ifom-ieo-campus.it>> wrote:
Hi,
we have a problem,
some multi-threaded binaries (namely bfast and bwa) can't be used in qlogin sessions. Apparently threads can't be spawned and applications have to be used in single-thread way.
Is there anything that i have to modify with qconf to allow that ?

Hi, Mauro.

SGE will, in general, not have anything to do with whether or not you can run multiple threads on a node.  SGE simply assumes that if the user asked for 4 slots, 4 will be used.  A user could use either more or fewer slots which might lead to inefficiencies, etc., but SGE will not restrict that from happening.  Therefore, it is important to know what command line is being used in the qlogin shell to run bwa and bfast.  We run bwa through SGE, in particular, on multiple threads daily.

Sean

Thanks !
6.2e3 - Centos5.3

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=291019

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net<mailto:users-unsubscribe at gridengine.sunsource.net>].




More information about the gridengine-users mailing list