[GE users] SGE failed to compile: undefined reference to sge_gdi2_send_any_request

reuti reuti at staff.uni-marburg.de
Fri Oct 29 12:17:34 BST 2010


Am 28.10.2010 um 21:19 schrieb jdm64:

>> I just tried it with Archlinux and the problem is in SGE's install script that it looks for /lib64 to determine the glibc version. This needs to be changed to /lib in util/arch to succeed (at least in the plain 64 bit version of ArchLinux). Then you can install it, but the sgemaster won't start AFAICS - nothing in SGE's or system's messages file, nor in /tmp though.
> 
> Ok, I guess I had the wrong fix. I made a system symlink to libc to where it was looking. Instead of changing util/arch in the installer.
> 
> You speak of sgemaster not being able to start? Is there any reason that you can think of why it wouldn't? Might compiling from source fix it?

Exactly, at the end of ./install_qmaster it only complains that it can't start the qmaster (I also tried by hand afterwards). But as said, absolutely no traces what's causing this (at least: I can't spot them).


>> So, back to the original question: what were your steps when running ./aimk and so on? There weren't any errors or warnings for incompleteness before this one?
> 
> Actually there were several errors, but I could fix all of them except this one because I'm not familiar with the makefiles. The other errors I ran into were:
> 
> 1) 3rdparty/sge_depend/{parse.c,def.h,main.c} all had a getline function that was conflicting with the systems getline. Fixed by renaming to getline2

This was never necessary for me in the past. What did happen when you don't change it?

I'm unsure, whether it's worth to port SGE to a new distribution, as for now the follow up versions are closed source. For now I wonder anyway, what's so special with ArchLinux to create these hassle. As the "install" is also not working in the installation procedure (to install the startup scripts by ./install_qmaster), it looks like it's not following Linux Standard Base (LSB) for these scripts.

-- Reuti 


> 2) Several references to files located outside the compile dir. "/off_home/gridengine/openssl-0.9.8h-origin/lx26-amd64/" and "scratch4/dg222156/source_check/gridengine/source/3rdparty/plpa/plpa-1.3.1/config/". Fixed my making symlinks to the required target.
> 
> 3) Similar to the current error, It couldn't find GE_LONGNAME or something similar. I don't remember exactly. Fixed by copying the string "Sun Grid Engine" into the locations that needed it -- or something similar.
> 
> As for the steps I used to compile. I read the README and did the following steps:
> 
> ./aimk -only-depend -no-dump
> ./scripts/zerodepend
> ./aimk -no-dump depend
> ./aimk  -no-dump -shared-libs -spool-berkeleydb
> 
> I'm stuck there with the current compiler errors.
> 
> Justin Madru

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=291035

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list