No subject


Wed Jan 12 20:38:46 GMT 2011


HOWEVER, the reporting appears to not be properly parsed or something.
Here's the tail of the reporting file:

1151613380:queue_consumable:all.q:k10:1151613380::slots=1.000000=8.000000
1151613383:acct:
all.q:k10:dps:otheus:sge_job_script.8006:672:sge:0:1151613373:11
51613382:1151613382:0:0:0:0:0:0.000000:0:0:0:0:9402:0:0:0.000000
:0:0:0:0:524:89:
NONE:defaultdepartment:NONE:1:0:0.000000:0.000000:0.000000:-U dps_users:
0.000000
:NONE:0.000000
1151613383:queue_consumable:all.q:k10:1151613383::slots=0.000000=8.000000


Now, I only got this far once I made sure that the sge.pm file was setting
the SGE_* environment variables properly.  I also followed another piece of
advice in altering the JobManager.pm module to output the log to /tmp.
Here's what I found in the other logs:

Thu Jun 29 22:07:55 2006 JM_SCRIPT:   script location:
/home/otheus/.globus/ef2c0c96-07aa-11db-9dc2-000423c068ae/sge_job_script.750
Thu Jun 29 22:07:55 2006 JM_SCRIPT:   email(s) will not be sent
Thu Jun 29 22:07:55 2006 JM_SCRIPT: Checking project details
Thu Jun 29 22:07:55 2006 JM_SCRIPT:   Project not specified
Thu Jun 29 22:07:55 2006 JM_SCRIPT: Determining job type
Thu Jun 29 22:07:55 2006 JM_SCRIPT:   Job is of type multiple
Thu Jun 29 22:07:55 2006 JM_SCRIPT:   forking multiple requests
Thu Jun 29 22:07:55 2006 JM_SCRIPT: SGE job script successfully built! :-)
Thu Jun 29 22:07:55 2006 JM_SCRIPT: Submitting a job
Thu Jun 29 22:07:55 2006 JM_SCRIPT:   successfully submitted

And that's it until I interrupt globusrun-ws.

Finally, there's container.log. And *This* contains something the previous
thread discussed but did not follow up on: missing
"globus-scheduler-provider-sge". Indeed I don't have one. But to my
knowledge, I am not trying to submit via MDS. So why is this even appearing?

2006-06-29 22:12:49,124 WARN  usefulrp.GLUEResourceProperty [GLUE refresher
0,runScript:315] Script Execution error when executing shell
/software/globus/gt4.0.2/libexec/globus-scheduler-provider-sge
java.io.IOException: java.io.IOException:
/software/globus/gt4.0.2/libexec/globus-scheduler-provider-sge: not found
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
        at java.lang.ProcessImpl.start(ProcessImpl.java:65)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
        at java.lang.Runtime.exec(Runtime.java:591)
        at java.lang.Runtime.exec(Runtime.java:429)
        at java.lang.Runtime.exec(Runtime.java:326)
        at
org.globus.mds.usefulrp.GLUEResourceProperty$PeriodicExecutor.runScript(
GLUEResourceProperty.java:299)
        at org.globus.mds.usefulrp.GLUEResourceProperty$PeriodicExecutor.run
(GLUEResourceProperty.java:260)
        at java.lang.Thread.run(Thread.java:595)

That's all I have. Ideas? Suggestions?

-- 
Otheus
otheus at gmail.com
+43.650.790.2571



More information about the gridengine-users mailing list