Custom Query (431 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (40 - 42 of 431)

Ticket Resolution Summary Owner Reporter
#162 fixed IZ963: Can't run HPUX binaries jeffbeadles
Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=963]

        Issue #:      963              Platform:     HP        Reporter: jeffbeadles (jeffbeadles)
       Component:     gridengine          OS:        HP-UX
     Subcomponent:    install          Version:      6.0beta      CC:    None defined
        Status:       VERIFIED         Priority:     P1
      Resolution:     FIXED           Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    andy (andy)
      QA Contact:     dom
          URL:
       * Summary:     Can't run HPUX binaries
   Status whiteboard:
      Attachments:

     Issue 963 blocks:
   Votes for issue 963:


   Opened: Thu Apr 8 09:39:00 -0700 2004 
------------------------


I mailed this to the dev list, but wanted to
make sure it's tracked and will be fixed in the
next release.

When trying to run install_execd;

"
./inst_sge[131]: 13757 Abort
/usr/lib/dld.sl: Can't open shared
library: /vol2/tools/SW/openssl-
0.9.7c/hp11/lib/libcrypto.sl.0.9.7
/usr/lib/dld.sl: No such file or directory
./inst_sge[57]: 13776 Abort(coredump)

Command failed: ./bin/hp11/qconf -sh

Probably a permission problem. Please check file
access permissions.
Check read/write permission. Check if SGE
daemons are running.
"

With a message like that, I know that it's not a
permission problem, but rather a missing shared
library.  So;

$ chatr bin/hp11/qconf
bin/hp11/qconf:
         shared executable
         shared library dynamic path search:
             SHLIB_PATH     disabled  second
             embedded path  disabled  first  Not
Defined
         shared library list:
             dynamic   /vol2/tools/SW/openssl-
0.9.7c/hp11/lib/libcrypto.sl.0.9.7
             dynamic   /usr/lib/libnsl.1
             dynamic   /usr/lib/libm.2
             dynamic   /usr/lib/libpthread.1
             dynamic   /usr/lib/libc.2
         shared library binding:
             deferred
         global hash table disabled
         plabel caching disabled
         global hash array size:1103
         global hash array nbuckets:3
         shared vtable support disabled
         static branch prediction disabled
         executable from stack: D (default)
         kernel assisted branch prediction
enabled
         lazy swap allocation disabled
         text segment locking disabled
         data segment locking disabled
         third quadrant private data space
disabled
         fourth quadrant private data space
disabled
         third quadrant global data space
disabled
         data page size: D (default)
         instruction page size: D (default)
         nulptr references disabled
         shared library private mapping disabled
         shared library text merging disabled

The problem is the line that reads;
"             SHLIB_PATH     disabled  second"

This says to not look in SHLIB_PATH for the
shared libraries.

To fix this, change the HP makefile/build rules
and add a "+s" to the link arguments for all of
the executables that need things from
$SHLIB_PATH.

It can also be modified post-build by running $
chatr +s enable bin/hp11/*

(I've verified that this works, at least on HPUX
11.11)

Regards,
        -Jeff

   ------- Additional comments from andy Mon Apr 19 05:01:01 -0700 2004 -------
Fixed in Beta2. Need feedback from user if it works

   ------- Additional comments from andy Mon Apr 19 05:02:17 -0700 2004 -------
.

   ------- Additional comments from jeffbeadles Tue Jul 13 07:31:50 -0700 2004 -------
Works great in the 6.0 "production" release.  Thanks Andy!
#166 duplicate IZ1010: Job array lack means to get email notification for the total array andreas
Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=1010]

        Issue #:      1010             Platform:     All           Reporter: andreas (andreas)
       Component:     gridengine          OS:        All
     Subcomponent:    qmaster          Version:      6.0beta2         CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     ernst
          URL:
       * Summary:     Job array lack means to get email notification for the total array
   Status whiteboard:
      Attachments:

     Issue 1010 blocks:
   Votes for issue 1010:


   Opened: Fri Apr 30 05:15:00 -0700 2004 
------------------------


DESCRIPTION:
There is a need for a means to sumit job arrays
in a way allowing email notifications be requested
for the total job.

Workaround:
The following solution helps only in the last
phase of the e-mail
delivery: from the e-mail daemon to the inbox. It
doesn't reduce the
number of e-mails generated by SGE nor the number
of messages that
have to pass through any intermediate e-mail daemons.

So, the solution is to use procmail for e-mail
filtering. procmail is
set to run from .forward and is handed the message
from the
daemon instead of writting it into the inbox.
Procmail has duplicate
mails detection capabilities, explained in 'man
procmailex'. You can
set it to check for the jobid and deliver only one
message per jobid.
procmail keeps a small cache of already seen
matching sequences and so
if the tasks take too long to complete while many
other jobs finish,
it might allow more than one message per jobid;
however the cache size
is configurable, so you can play with it to obtain
the best results.

   ------- Additional comments from sgrell Mon Dec 12 02:55:45 -0700 2005 -------
Changed the Subcomponent.

Stephan
#171 fixed IZ1028: Allow SIGTRAP to enable debugging uddeborg
Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=1028]

        Issue #:      1028             Platform:     All        Reporter: uddeborg (uddeborg)
       Component:     gridengine          OS:        All
     Subcomponent:    execution        Version:      6.0beta2      CC:    None defined
        Status:       STARTED          Priority:     P3
      Resolution:                     Issue type:    PATCH
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     pollinger
          URL:
       * Summary:     Allow SIGTRAP to enable debugging
   Status whiteboard:
      Attachments:
                      Date/filename:                    Description:                                          Submitted by:
                      Fri May 7 00:11:00 -0700 2004: ## Minimum patch to just allow SIGTRAP too. (text/plain) uddeborg

     Issue 1028 blocks:
   Votes for issue 1028:


   Opened: Fri May 7 00:10:00 -0700 2004 
------------------------


I am trying to debug some problems I have with the
beta 2, and in the process wanted to run sge_execd
and sge_shepherd under the debugger.  That didn't
work.  After a while I realised it is because the
application blocks the SIGTRAP signal.

In sig_handlers.c actually all signals but a
selected set is blocked.  I don't see why this is
a good idea, but maybe I miss something.  In any
case I think allowing SIGTRAP would make sense.

   ------- Additional comments from uddeborg Fri May 7 00:11:30 -0700 2004 -------
Created an attachment (id=14)
Minimum patch to just allow SIGTRAP too.

   ------- Additional comments from andreas Fri Jun 17 06:11:16 -0700 2005 -------
Chaned to execution.

   ------- Additional comments from roland Mon Jun 20 00:43:51 -0700 2005 -------
take it

   ------- Additional comments from roland Mon Jun 20 06:07:09 -0700 2005 -------
I've enabled SIGTRAP for the shepard in our maintrunk. We need to verify that
this doesn't lead to any negative effects.
Note: See TracQuery for help on using queries.