Custom Query (431 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (91 - 93 of 431)

Ticket Resolution Summary Owner Reporter
#1589 fixed [PATCH] Remove connection limit based on FD_SETSIZE Daniel Kobras <d.kobras@…> sckobras
Description

The changeset https://arc.liv.ac.uk/trac/SGE/changeset/20140406123948-0ed77-974278d41c87f2f53e735ad9d271fc2c211d3395/sge (Assume POSIX poll available) got rid of the conditional USE_POLL, but the changes to cl_commlib.c contained two glitches where #ifndef USE_POLL was treated like #ifdef USE_POLL, ie. the preprocessor directives were removed, but the enclosed code block was not. As a result, the releases 8.1.7 up to 8.1.9 impose a connection limit based on FD_SETSIZE, even though poll() is used instead of select(). The attached patch removes both leftover hunks from the original changeset, which means that connections are limited by resource constraints again, as they should be. It fixes connection problems in larger environments with 1000 or more hosts.

#1591 fixed [PATCH] 8.1.9 build failure with high parallelism afif
Description

As reported in Debian #846770 [1], gridengine fails to build if trying with 64 threads. The problem turns out to be some undeclared prerequisites for the pdc target. The attached patch fixes it for me. The patch is against the v8.1.9 code base.

Thanks and regards Afif

  1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=846770

-- Afif Elghraoui | عفيف الغراوي http://afif.ghraoui.name

source-dependencies.patch

#1573 worksforme [8.1.9] Installation error from source remyd1
Description

Step to reproduce the bugs:

yum install -y wget tar wget http://arc.liv.ac.uk/downloads/SGE/releases/8.1.9/sge-8.1.9.tar.gz tar -xvf sge-8.1.9.tar.gz cd sge-8.1.9 mkdir /opt/sge export SGE_ROOT=/opt/sge yum install -y java-1.8.0-openjdk.x86_64 csh make gcc ant man-1.6f-32.el6 cd source/ sh scripts/bootstrap.sh ./aimk -man -htmlman -with-munge -pam -spool-classic echo y | scripts/distinst -nobdb -local -noexit -allall lx-amd64

I tried this on centos6/amd64 and ubuntu16.04/amd64 (replacing

yum with apt java-1.8.0-openjdk.x86_64 with openjdk-8-jdk man-1.6f-32.el6 with man2html

), and I have the same error. Some binaries are not produced. I am using the last release, the 8.1.9.

The error:

&<--------------------------------------------&< GUI installer part done

sgeinspect dir "../nbgui" does not exist Checking and creating binary directories Installing binaries for lx-amd64 from /root/sge-8.1.9/source/LINUXAMD64 -->

--> /opt/sge/bin/lx-amd64


Installing sge_qmaster cp: cannot stat `sge_qmaster': No such file or directory

... Installing ../3rdparty/remote/LINUXAMD64/rlogin cp: cannot stat `../3rdparty/remote/LINUXAMD64/rlogin': No such file or directory

This command failed: cp ../3rdparty/remote/LINUXAMD64/rlogin /opt/sge/utilbin/lx-amd64/rlogin

chown: cannot access `/opt/sge/utilbin/lx-amd64/rlogin': No such file or directory

This command failed: chown 0 /opt/sge/utilbin/lx-amd64/rlogin

chgrp: cannot access `/opt/sge/utilbin/lx-amd64/rlogin': No such file or directory

This command failed: chgrp 0 /opt/sge/utilbin/lx-amd64/rlogin

chmod: cannot access `/opt/sge/utilbin/lx-amd64/rlogin': No such file or directory

This command failed: chmod 4755 /opt/sge/utilbin/lx-amd64/rlogin

Installing job binaries


Installing work cp: cannot stat `work': No such file or directory

This command failed: cp work /opt/sge/utilbin/lx-amd64/work

chown: cannot access `/opt/sge/utilbin/lx-amd64/work': No such file or directory

This command failed: chown 0 /opt/sge/utilbin/lx-amd64/work

chgrp: cannot access `/opt/sge/utilbin/lx-amd64/work': No such file or directory

This command failed: chgrp 0 /opt/sge/utilbin/lx-amd64/work

chmod: cannot access `/opt/sge/utilbin/lx-amd64/work': No such file or directory

This command failed: chmod 755 /opt/sge/utilbin/lx-amd64/work

Installing shared libraries


&<--------------------------------------------&<

Note: See TracQuery for help on using queries.