Opened 13 years ago

Last modified 9 years ago

#1027 new enhancement

IZ86: add_checkpointobj should have fast_add option

Reported by: joga Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: Keywords: framework
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=86]

        Issue #:      86              Platform:     All           Reporter: joga (joga)
       Component:     testsuite          OS:        All
     Subcomponent:    framework       Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P3
      Resolution:     FIXED          Issue type:    ENHANCEMENT
                                  Target milestone: milestone 1
      Assigned to:    issues@testsuite
      QA Contact:     joga
          URL:
       * Summary:     add_checkpointobj should have fast_add option
   Status whiteboard:
      Attachments:

     Issue 86 blocks:
   Votes for issue 86:     Vote for this issue


   Opened: Thu Nov 23 01:17:00 -0700 2006 
------------------------


This was IZ 1963 in project gridengine.

procedure add_checkpointobj in gridengine/testsuite/tcl_files/sge_checkpoint.tcl
should have fast_add option, which allows faster adding of a checkpoint object
from file, like for instance mod_heckpointobj in sge_checkpoint.60.tcl

In general, cleanup the sge_checkpoint.tcl to conform to interfaces and style of
other modules (e.g. compare with sge_host.tcl).

   ------- Additional comments from aja Wed Aug 1 11:05:38 -0700 2007 -------
*** Issue 2 has been marked as a duplicate of this issue. ***

   ------- Additional comments from aja Thu Aug 2 06:04:31 -0700 2007 -------
.

   ------- Additional comments from aja Fri Apr 10 06:41:03 -0700 2009 -------
enhancement of checkpoint object interface:

set_ckpt_defaults {change_array}
add_ckpt {ckpt_name {change_array ""} {fast_add 1} {on_host ""} {as_user
""} {raise_error 1}}
mod_ckpt {ckpt_name change_array {fast_add 1} {on_host ""} {as_user  ""}
{raise_error 1} }
get_ckpt {ckpt_name {output_var result} {on_host ""} {as_user ""}
{raise_error 1}}
del_ckpt { ckpt_name {on_host ""} {as_user ""} {raise_error 1} }
get_ckpt_list {{output_var result} {on_host ""} {as_user ""}
{raise_error 1}}

Change History (0)

Note: See TracTickets for help on using tickets.