Opened 13 years ago

Last modified 9 years ago

#1035 new defect

IZ94: parse_qstat does not process correctly last entry

Reported by: joga Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: Keywords: framework
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=94]

        Issue #:      94              Platform:     All           Reporter: joga (joga)
       Component:     testsuite          OS:        All
     Subcomponent:    framework       Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P3
      Resolution:     FIXED          Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    ovid (ovid)
      QA Contact:     joga
          URL:
       * Summary:     parse_qstat does not process correctly last entry
   Status whiteboard:
      Attachments:

     Issue 94 blocks:
   Votes for issue 94:     Vote for this issue


   Opened: Fri Nov 24 04:23:00 -0700 2006 
------------------------


This was IZ 2024 in project gridengine.

parse_qstat does not seem to parse correctly last entry:


qstat_plain_output(1123,id)     = 1123
qstat_plain_output(1123,jatask) = {} {}
qstat_plain_output(1123,master) = 1 {}
qstat_plain_output(1123,name)   =
qstat_plain_output(1123,prior)  =
qstat_plain_output(1123,queue)  = {} {}
qstat_plain_output(1123,state)  =
qstat_plain_output(1123,time)   =
qstat_plain_output(1123,user)   =

Here's the output from the CLI:

   ------- Additional comments from joga Fri Nov 24 04:25:00 -0700 2006 -------
Ovid, please verify this issue.
It might already be fixed by now.

   ------- Additional comments from ovid Fri Dec 1 14:46:00 -0700 2006 -------
Checked if issue is fixed. Found the following;

   - in SGE 6.0 u4, issues is fixed in branch

testsuite/src/checktree/system_tests/clients/qstat

   - in GE TEST_GDI2, issues seems NOT to be fixed in branch

testsuite/src/checktree/system_tests/clients/qstat

I have verified this in 2 seperate configurations, one with Solaris 9 as
testsuite master and tDOM host, another with Linux Red Hat testsuite master
and tDOM host.

So,  is there an issue with some of the files in the two branches not matching?

The problem is in the parse_qstat routine.

The files look like this:

sgetest@dt218-123# ls -altr sge_procedures.tcl
-rw-rw-r--    1 sgetest  sgegroup   267554 Sep 26 01:27 sge_procedures.tcl
sgetest@dt218-123# pwd
/array2/gridengine_testing/source/N1GE6/testsuite/src/tcl_files

[root@dt218-130 tcl_files]# ls -latr sge_procedures.tcl
-rw-r--r--    1 sgetest  sgegroup   253517 Nov 29 10:03 sge_procedures.tcl
[root@dt218-130 tcl_files]# pwd
/array2/gridengine_testing/source/N1GE6.5/testsuite/src/tcl_files


Any thoughts on the difference?


   ------- Additional comments from ovid Fri Oct 5 13:30:01 -0700 2007 -------
Fixed GE 6.1

Change History (0)

Note: See TracTickets for help on using tickets.