Opened 13 years ago

Last modified 9 years ago

#1050 new defect

IZ109: job_environment fails on some architectures

Reported by: crei Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: Keywords: tests
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=109]

        Issue #:      109             Platform:     Other         Reporter: crei (crei)
       Component:     testsuite          OS:        other
     Subcomponent:    tests           Version:      current          CC:    None defined
        Status:       NEW             Priority:     P3
      Resolution:                    Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    issues@testsuite
      QA Contact:     joga
          URL:
       * Summary:     job_environment fails on some architectures
   Status whiteboard:
      Attachments:

     Issue 109 blocks:   110 110
   Votes for issue 109:         Vote for this issue


   Opened: Mon Jan 15 07:50:00 -0700 2007 
------------------------


checktree/functional/job_environment test failes on some architectures with
the following error message:

Shared library path is unset, with INHERIT_ENV=true,SET_LIB_PATH=false
(queue=all.q@angbor)

==> on some architectures (here linux26) the exported LD_LIBRARY_PATH seems not
to be inherit to the execd/shepherd child job processes

The testsuite does not expect this.

In order to solve the problem the root cause of the not existing LD_LIBRARY_PATH
must be found out.

If it is architecture specific the GE documentation should be enhanced also!

   ------- Additional comments from crei Mon Jan 15 09:51:04 -0700 2007 -------
issue 110 has likewise the same problem

Change History (0)

Note: See TracTickets for help on using tickets.