Opened 9 years ago

Last modified 6 years ago

#1102 new defect

IZ161: drmaaj test: 1 of the JUnit tests is broken

Reported by: joga Owned by:
Priority: high Milestone:
Component: testsuite Version: current
Severity: Keywords: tests
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=161]

        Issue #:      161             Platform:     All           Reporter: joga (joga)
       Component:     testsuite          OS:        All
     Subcomponent:    tests           Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P2
      Resolution:     INVALID        Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    issues@testsuite
      QA Contact:     joga
          URL:
       * Summary:     drmaaj test: 1 of the JUnit tests is broken
   Status whiteboard:
      Attachments:

     Issue 161 blocks:
   Votes for issue 161:     Vote for this issue


   Opened: Tue Nov 13 06:21:00 -0700 2007 
------------------------


When running the Java DRMAA test (api/drmaaj),
it reports one failure. This looks like a test issue (in the JUnit test) to me.
It tries to access a file in /tmp, and the filename suggests, that the file is
generated on a different host (in this hosts local /tmp), therefore the test fails.

Output from the test:
junit.framework.AssertionFailedError: Unable to run script job
        at junit.framework.Assert.fail(Assert.java:47)
        at com.sun.grid.drmaa.Issues$Thread1770.run(Issues.java:234)
F
Time: 867.317
There was 1 failure:
1) testIssue1770(com.sun.grid.drmaa.Issues)junit.framework.AssertionFailedError:
Unable to open output file for first category (/tmp/1770oin22305)
        at com.sun.grid.drmaa.Issues.testIssue1770(Issues.java:159)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

FAILURES!!!
Tests run: 146,  Failures: 1,  Errors: 0

   ------- Additional comments from dagru Wed Jun 4 07:02:33 -0700 2008 -------
Can not reproduce this issue even on same machine. Because job is submitted
on host, which is set in testuite via:

set env_list "$env_list -Dgets.hostname=\"$local_host\""

it must be the localhost. So the output of job is on same host
which submitted the job.

Change History (0)

Note: See TracTickets for help on using tickets.