Opened 12 years ago

Last modified 9 years ago

#1111 new defect

IZ170: remove ts_def_con connection wrapping for CHECK_USER

Reported by: crei Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: Keywords: framework
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=170]

        Issue #:      170             Platform:     All           Reporter: crei (crei)
       Component:     testsuite          OS:        All
     Subcomponent:    framework       Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P3
      Resolution:     FIXED          Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    crei (crei)
      QA Contact:     joga
          URL:
       * Summary:     remove ts_def_con connection wrapping for CHECK_USER
   Status whiteboard:
      Attachments:

     Issue 170 blocks:
   Votes for issue 170:     Vote for this issue


   Opened: Wed Jan 9 03:39:00 -0700 2008 
------------------------


Currently the testsuite creates some wrapper connections for the CHECK_USER
if the user name starts with "ts_def_con". This is done for long running
commands (like tail -f) which running in a shell.

The problem is that the current testsuite code is using lots of different
"ts_def_con_XXXXX" connections and this connects are never closed.

Aim of the issue is to cleanup the remote connection handling in TS to detect
automatically that a user session is blocked by a command and start a new
session for the user AND also close not used active sessions.

The "ts_def_con_XXXXX" user name should not be supported anymore and be replaced
by the correct user name.

   ------- Additional comments from crei Wed Jan 9 03:39:33 -0700 2008 -------
working on this issue ...

   ------- Additional comments from crei Thu Jan 31 02:46:17 -0700 2008 -------
starting now

   ------- Additional comments from crei Thu Feb 7 08:27:20 -0700 2008 -------
fixed with CR-2008-02-06-0

Change History (0)

Note: See TracTickets for help on using tickets.