Opened 11 years ago

Last modified 9 years ago

#1152 new defect

IZ211: Testsuite configuration - can't change the source dir

Reported by: aja Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: Keywords: framework
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=211]

        Issue #:      211             Platform:     All           Reporter: aja (aja)
       Component:     testsuite          OS:        All
     Subcomponent:    framework       Version:      current          CC:    None defined
        Status:       STARTED         Priority:     P3
      Resolution:                    Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    aja (aja)
      QA Contact:     joga
          URL:
       * Summary:     Testsuite configuration - can't change the source dir
   Status whiteboard:
      Attachments:

     Issue 211 blocks:
   Votes for issue 211:     Vote for this issue


   Opened: Wed Jul 16 02:21:00 -0700 2008 
------------------------


Testsuite configuration - can't change the SGE source directory - there is a
dependency - cvs release tag.

There is a possibility to enhance the configuration by adding some parameter
dependency mechanism, sice there are more dependencies.

   ------- Additional comments from aja Thu Jul 17 02:42:01 -0700 2008 -------
Another configuration issue:

----------------------------------------------------------
Testsuite's directory to save test results (html/txt files)
----------------------------------------------------------
Enter the full pathname of the testsuite results directory, or
press >RETURN< to use the default value.
The testsuite will use this directory to save test results and
internal data.
(default: /cod_home/aja/devel/testsuite/src/results)
> /cod_home/apj/results/sge62
can't create directory "/cod_home/apj": permission denied
    while executing
"file mkdir $value "
    (procedure "config_verify_directory" line 11)
    invoked from within
"config_verify_directory $value $create_new"
    ("directory+" arm line 6)
    invoked from within
"switch -- $check_type {
            "port" {
               if { [config_verify_port $value] == -1 } {
                  return -1
         }
        ..."
    (procedure "config_generic" line 189)
    invoked from within
"config_generic $only_check $name config $help_text "directory+" 0"
    (procedure "config_results_dir" line 21)
    invoked from within
"$procedure_name 0 $p_name config "
    (procedure "verify_config2" line 127)
    invoked from within
"verify_config2 config $only_check error_list $actual_ts_config_version"
    (procedure "verify_config" line 6)
    invoked from within
"verify_config ts_config 0 err_list "
    (procedure "setup2" line 85)
    invoked from within
"setup2"
    (procedure "setup2" line 158)
    invoked from within
"setup2"
    (file "check.exp" line 8448)

   ------- Additional comments from aja Thu Aug 7 01:31:03 -0700 2008 -------
Fixed the problem with changing SGE source directory.

Change History (0)

Note: See TracTickets for help on using tickets.