Opened 11 years ago

Last modified 8 years ago

#1176 new defect

IZ235: Unsecured hedeby system installation fails

Reported by: easymf Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: minor Keywords: Sun hedeby
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=235]

        Issue #:      235             Platform:     Sun           Reporter: easymf (easymf)
       Component:     testsuite          OS:        All
     Subcomponent:    hedeby          Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P1
      Resolution:     FIXED          Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    easymf (easymf)
      QA Contact:     crei
          URL:
       * Summary:     Unsecured hedeby system installation fails
   Status whiteboard:
      Attachments:

     Issue 235 blocks:
   Votes for issue 235:     Vote for this issue


   Opened: Wed Aug 13 02:46:00 -0700 2008 
------------------------


Description:

If TS is set to use hedeby in usecured mode (26 -> 4 -> 5 -> 2), installation of
system fails with following message:

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
SEVERE
runlevel    : "short", (0)
check       : hedeby_install
procedure   : startup_hedeby_hosts
called from : hedeby_startup_master_host
----------------------------------------------------------------
cannot set security disable property on host ge1:
Error: System property ssl_disable is not supported
----------------------------------------------------------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Evaluation:

The problem is high priority, because it prevents from testing the unsecured
hedeby installation.

Suggested Fix / Work Around:

No workaround possible, has to be fixed.

Analysis:

Problem is caused by using wrong bootstrap config property name (ssl_disable
instead of no_ssl) in checktree_hedeby/util.tcl, line 2003, 2020.

How to test:

Start installation of the unsecured hedeby system from TS and manually check if
it pass.

ETC:

   0.5 PD  for the fix

ATC:

   ------- Additional comments from easymf Wed Aug 13 02:47:58 -0700 2008 -------
i have fix ready

   ------- Additional comments from easymf Wed Aug 13 02:48:15 -0700 2008 -------
i have fix ready

   ------- Additional comments from easymf Wed Aug 13 03:18:26 -0700 2008 -------
fixed with MB-2008-08-13-0

Change History (1)

comment:1 Changed 8 years ago by dlove

  • Priority changed from highest to normal
  • Severity set to minor
Note: See TracTickets for help on using tickets.