Opened 11 years ago

Last modified 8 years ago

#1177 new patch

IZ236: ge_stop_and_free_resources does not wait for stopped service

Reported by: torsten Owned by:
Priority: high Milestone:
Component: testsuite Version: current
Severity: minor Keywords: Sun hedeby
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=236]

        Issue #:      236             Platform:     Sun           Reporter: torsten (torsten)
       Component:     testsuite          OS:        All
     Subcomponent:    hedeby          Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P2
      Resolution:     FIXED          Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    crei (crei)
      QA Contact:     crei
          URL:
       * Summary:     ge_stop_and_free_resources does not wait for stopped service
   Status whiteboard:
      Attachments:
                      Date/filename:                        Description:                                            Submitted by:
                      Wed Aug 20 00:36:00 -0700 2008: patch untested patch to give an idea for the fix (text/plain) torsten

     Issue 236 blocks:
   Votes for issue 236:     Vote for this issue


   Opened: Wed Aug 20 00:34:00 -0700 2008 
------------------------


Step 1 of the ge_stop_and_free_resources does a 'sdmadm sds -fr' on all
geadapters. Step 2 waits for all non static resources to appear in the
spare_pool. Step 3 starts the geadapters again.

The problem is that step 2 should also wait for the geadapter services to be
actually in sstate "STOPPED". Otherwise there can be an illegal state transition
during the startup in step 3 which leads to a failing test case.

   ------- Additional comments from torsten Wed Aug 20 00:36:37 -0700 2008 -------
Created an attachment (id=3)
untested patch to give an idea for the fix

   ------- Additional comments from crei Wed Aug 20 04:17:02 -0700 2008 -------
Used the attached patch from torsten and modified it a little bit

Fixed with checkin CR-2008-08-20-0

Attachments (1)

3 (2.1 KB) - added by trac 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by trac

  • Attachment 3 added

comment:1 Changed 8 years ago by dlove

  • Severity set to minor
  • Type changed from defect to patch
Note: See TracTickets for help on using tickets.