Opened 10 years ago

Last modified 8 years ago

#1235 new defect

IZ294: Many of the qstat xml tests are broken

Reported by: crei Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: minor Keywords: tests
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=294]

        Issue #:      294             Platform:     All           Reporter: crei (crei)
       Component:     testsuite          OS:        All
     Subcomponent:    tests           Version:      current          CC:    None defined
        Status:       NEW             Priority:     P1
      Resolution:                    Issue type:    DEFECT
                                  Target milestone: milestone 1
      Assigned to:    issues@testsuite
      QA Contact:     joga
          URL:
       * Summary:     Many of the qstat xml tests are broken
   Status whiteboard:
      Attachments:

     Issue 294 blocks:
   Votes for issue 294:     Vote for this issue


   Opened: Tue Mar 10 03:45:00 -0700 2009 
------------------------


Many of the qstat xml output compare tests are disabled in the test
"checktree/system_tests/clients/qstat".

The xml tests are only done when the tDOM package is available. We should
change the tests to fail if the tDOM package is not available on the test host.

   ------- Additional comments from crei Fri Apr 17 07:37:48 -0700 2009 -------
Even with available tDOM package some tests fail with TCL error or test errors
which provide not understandable error messages.

This tests must be reworked before makeing them default.

Examples:
--------------------------------------------------------------------------------
error in plain, XML qstat -g c
--------------------------------------------------------------------------------
Stack Trace:
============
  0: toplevel
  1: menu
  2: run_tests root 0
  3: run_test testsuite/src/checktree/system_tests/clients/qstat 0
  4: run_test_level testsuite/src/checktree/system_tests/clients/qstat 0 0 1 0
  5: qstat_g_c_plain_xml_comparison

----------------------------------------------------------------------------
TCL Error
invalid command name ""
invalid command name ""
    while executing
"$jobArgs nodeValue"
    (procedure "qstat_j_xml_par" line 55)
    invoked from within
"qstat_j_xml_par xml $job_id $xmloutput"
    (procedure "test_qstat_j_xml" line 50)
    invoked from within
"$elem"

Change History (1)

comment:1 Changed 8 years ago by dlove

  • Priority changed from highest to normal
  • Severity set to minor
Note: See TracTickets for help on using tickets.