Opened 7 years ago

Last modified 7 months ago

#1305 new enhancement

Build dependencies doc

Reported by: cpeel Owned by:
Priority: normal Milestone:
Component: sge Version: 6.2u5
Severity: minor Keywords:
Cc:

Description

Given the "With appropriate development packages installed — they need documenting" wording on the main page, here's an attempt to doc them.

Package names for Fedora 14:
csh
java-1.6.0-openjdk-devel
openssl-devel
db4-devel
pam-devel
X11-devel
libXt-devel
lesstif-devel (openmotif-devel instead?)
libXmu
libXmu-devel
libXmu
libXpm-devel
byacc

The sge.spec from http://www.biopackages.net/stable/centos/4/SRPMS/sge-6.1u2-1.15.bp.centos4.src.rpm also includes:
libgcj-devel
xorg-x11-devel
gcc
/usr/bin/perl

Change History (3)

comment:1 Changed 7 years ago by dlove

Yes, thanks. I intended to dig that out, along with a Debian version, at least.

comment:2 Changed 6 years ago by Jesse Becker

Packages needed to build on Fedora 15:

db4-cxx
db4-devel
hwloc
hwloc-devel
imake
keyutils-libs-devel
krb5-devel
lesstif-devel
libcom_err-devel
libICE-devel
libselinux-devel
libsepol-devel
libSM-devel
libXext-devel
libxml2-devel
libXmu-devel
libXp-devel
libXt-devel
openssl-devel
openssl-static
pam-devel
pciutils-devel
tcsh
tokyocabinet
tokyocabinet-devel

--
Jesse Becker
NHGRI Linux support (Digicon Contractor)

comment:3 Changed 6 years ago by dlove

I don't understand these dependencies, like how a bunch of them would be
needed -- some just look bizarre -- and why others I expect to be
required -- like ncurses -- aren't.

Any idea why they're so different from the Fedora version of gridengine,
apart from hwloc? I don't have a Fedora installation to try.

Note: See TracTickets for help on using tickets.