Opened 8 years ago

Closed 8 years ago

#1349 closed defect (fixed)

RHEL 6 build problems

Reported by: Florian.LaRoche@… Owned by: dlove
Priority: normal Milestone: 8.0.0b
Component: sge Version: 8.0.0a
Severity: minor Keywords:
Cc:

Description

Hello,

I've compiled the current gridengine source rpm with the Red Hat
buildsystem koji and put the rpm packages here:

    http://jur-linux.org/rpms/el-updates/5/
    http://jur-linux.org/rpms/el-updates/6/

For RHEL6 the following cludgy changes did make it compile:
--- gridengine.spec
+++ gridengine.spec
@@ -152,7 +152,7 @@

 # -O2/-O3 gives warnings about type puns.  It's not clear whether
 # they're serious, but -fno-strict-aliasing just in case.
-export SGE_INPUT_CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
+export SGE_INPUT_CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -I /usr/include/freetype2"
 [ -n "$RPM_BUILD_NCPUS" ] && parallel_flags="-parallel $RPM_BUILD_NCPUS"
 %if %{without java}
 JAVA_BUILD_OPTIONS="-no-java -no-jni"
@@ -182,8 +182,8 @@
   rm man/man8/SGE_Helper_Service.exe.8
   rm -r util/gui-installer util/sgeSMF
   rm start_gui_installer
-  for l in lib/*/libdrmaa.so.1; do
-    ( cd $(dirname $l); ln -sf libdrmaa.so.1 libdrmaa.so; )
+  for l in lib/*/libdrmaa.so.1.0; do
+    ( cd $(dirname $l); ln -sf libdrmaa.so.1.0 libdrmaa.so; )
   done
   gzip man/man*/*
 )


Please let me know if you run these rpms and they work out ok for you.

best regards,

Florian La Roche

Change History (3)

comment:1 Changed 8 years ago by dlove

SGE <sge-bugs@liverpool.ac.uk> writes:

>  I've compiled the current gridengine source rpm with the Red Hat
>  buildsystem koji and put the rpm packages here:

Thanks.  I didn't know about that, but was planning on looking into the
opensuse build system.  I must get on to the Fedora maintainer and try
to interest him in v8...

>      http://jur-linux.org/rpms/el-updates/5/
>      http://jur-linux.org/rpms/el-updates/6/
> 
>  For RHEL6 the following cludgy changes did make it compile:
>  --- gridengine.spec
>  +++ gridengine.spec
>  @@ -152,7 +152,7 @@
> 
>   # -O2/-O3 gives warnings about type puns.  It's not clear whether
>   # they're serious, but -fno-strict-aliasing just in case.
>  -export SGE_INPUT_CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
>  +export SGE_INPUT_CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -I/usr/include/freetype2"

Yes.  Someone else reported that problem, and I'd just looked up that in
the EPEL package.  It looks like a Red Hat regression, but I was
planning to put an equivalent workaround in aimk.

>   [ -n "$RPM_BUILD_NCPUS" ] && parallel_flags="-parallel $RPM_BUILD_NCPUS"
>   %if %{without java}
>   JAVA_BUILD_OPTIONS="-no-java -no-jni"
>  @@ -182,8 +182,8 @@
>     rm man/man8/SGE_Helper_Service.exe.8
>     rm -r util/gui-installer util/sgeSMF
>     rm start_gui_installer
>  -  for l in lib/*/libdrmaa.so.1; do
>  -    ( cd $(dirname $l); ln -sf libdrmaa.so.1 libdrmaa.so; )
>  +  for l in lib/*/libdrmaa.so.1.0; do
>  +    ( cd $(dirname $l); ln -sf libdrmaa.so.1.0 libdrmaa.so; )

I didn't know about that one, and it looks as if I should have spotted
it; in fact, I have such a link in my installation somehow.

>  Please let me know if you run these rpms and they work out ok for you.

I can't currently check the RH6 stuff until I can rebuild a VM image
with enough space, but thanks in the meantime.  I'll put a reference to
the packages somewhere.

comment:2 Changed 8 years ago by dlove

  • Milestone set to 8.0.0b
  • Owner set to dlove
  • Status changed from new to accepted
  • Summary changed from RHEL 6 binaries to RHEL 6 build problems

comment:3 Changed 8 years ago by dlove

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed by [4008]

Note: See TracTickets for help on using tickets.