Opened 8 years ago

Closed 8 years ago

#1350 closed defect (duplicate)

[SGE-bugs] Error building from src.rpm on RHEL 6

Reported by: dlove Owned by:
Priority: normal Milestone:
Component: sge Version: 8.0.0a
Severity: minor Keywords:
Cc:

Description

Adam DeConinck <adeconinck@rsystemsinc.com> writes:

> On 8/10/2011 9:07 AM, Dave Love wrote:
>> Adam DeConinck <adeconinck@rsystemsinc.com> writes:
>>
>>> Downloaded gridenine-8.0.0a-2.src.rpm from
>>> http://arc.liv.ac.uk/downloads/SGE/releases/8.0.0a/.  Server is a test
>>> machine running RHEL 6.1 x86_64.  Installed the src rpm (as root), and
>>> confirmed that all dependencies were in place, then ran "rpmbuild -bb
>>> --without java gridengine.spec"
>>>
>>> Build failed with the following output:
>>>
>>> echo libXmt.a
>>> libXmt.a
>>> gcc -c -DALLOW_COLUMN_RESIZE -DDRAW_RESIZE_SHADOW -I../Xmt310
>>> -DSGE_ARCH_STRING=\"lx-amd64\" -O3 -Wall -Wstrict-prototypes -DUSE_POLL
>>> -DLINUX -DLINUXAMD64 -DLINUXAMD64 -D_GNU_SOURCE -DGETHO
>>> gcc -c -DALLOW_COLUMN_RESIZE -DDRAW_RESIZE_SHADOW -I../Xmt310
>>> -DSGE_ARCH_STRING=\"lx-amd64\" -O3 -Wall -Wstrict-prototypes -DUSE_POLL
>>> -DLINUX -DLINUXAMD64 -DLINUXAMD64 -D_GNU_SOURCE -DGETHO
>>> gcc -c -DALLOW_COLUMN_RESIZE -DDRAW_RESIZE_SHADOW -I../Xmt310
>>> -DSGE_ARCH_STRING=\"lx-amd64\" -O3 -Wall -Wstrict-prototypes -DUSE_POLL
>>> -DLINUX -DLINUXAMD64 -DLINUXAMD64 -D_GNU_SOURCE -DGETHO
>>> In file included from /usr/include/X11/Xft/Xft.h:39,
>>>                  from /usr/include/Xm/TextFP.h:47,
>>>                  from ../Xbae/CellP.h:35,
>>>                  from ../Xbae/Cell.c:28:
>>> /usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: No
>>> such file or directory

This definitely looks like a system problem, but I don't understand the
problem on RH6 yet.  On RH5

  $ cc -E - >/dev/null <<+
  #include <Xm/TextFP.h>
  +

works, but on RH6, it complains about the file, as above and, in fact,
including just Xft.h fails as above.

I see that the EPEL gridengine package has added

  export SGE_INPUT_CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/freetype2"

to the spec %build section before running aimk, but I think I'll put a
workaround in aimk -- patch available shortly.

Thanks for the report.

Change History (1)

comment:1 Changed 8 years ago by dlove

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1349 (which has more info).
Original report lost by email2trac.

Note: See TracTickets for help on using tickets.