Opened 13 years ago

Closed 7 years ago

#142 closed defect (fixed)

IZ820: scheduler crashes in functional ticket calculation on AMD64

Reported by: andy Owned by:
Priority: high Milestone:
Component: sge Version: 6.0alpha
Severity: minor Keywords: Linux kernel
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=820]

        Issue #:      820              Platform:     Other      Reporter: andy (andy)
       Component:     gridengine          OS:        Linux
     Subcomponent:    kernel           Version:      6.0alpha      CC:    None defined
        Status:       VERIFIED         Priority:     P2
      Resolution:     FIXED           Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    sgrell (sgrell)
      QA Contact:     andreas
          URL:
       * Summary:     scheduler crashes in functional ticket calculation on AMD64
   Status whiteboard:
      Attachments:

     Issue 820 blocks:
   Votes for issue 820:


   Opened: Tue Mar 9 06:18:00 -0700 2004 
------------------------


scheduler crashes in functional ticket calculation
on AMD64

The crash happens already with a few jobs (e.g.
200) when functional tickets are set to a non-zero
value and functional shares are configured for a
few projects, users and departments.

There is a strong indication of a heap corrpution
since the crash occurs in completely different
functions. Also a busy infinite loop in the
malloc() call has been seen.

So far it only could be reproduced on Linux AMD64.

The crash also happens in SGEEE 5.3p5.

   ------- Additional comments from sgrell Tue Mar 9 06:57:22 -0700 2004 -------
reassigned

Tested under solaris64 and does not crash!

   ------- Additional comments from sgrell Tue Mar 9 06:57:49 -0700 2004 -------
lets see.....

   ------- Additional comments from sgrell Wed Mar 10 06:26:30 -0700 2004 -------
I think it is fixed. At least it did not crash anymore after
my changes, but I did not understand the bug.

Stephan

   ------- Additional comments from andreas Fri Apr 30 05:29:46 -0700 2004 -------
Seemingly fixed a users problems with
and AMD Opteron qmaster/scheduler linux box.
The following configuration was in use:


rpm -qa | grep glib
glib-1.2.10-10
glibc-kernheaders-2.4-8.10
glib2-devel-2.2.1-1
glibc-common-2.3.2-27.9
glib2-2.2.1-1
glib-devel-1.2.10-10
glibc-2.3.2-27.9
glibc-devel-2.3.2-27.9

Kernel rev
lsf-k8 2.4.24-1aslsmp

Distribution
RedHat 9

Change History (1)

comment:1 Changed 7 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.