Opened 6 years ago

Closed 6 years ago

#1478 closed defect (fixed)

Installation Bugs

Reported by: tobeychris@… Owned by: Dave Love <d.love@…>
Priority: normal Milestone:
Component: sge Version: 8.1.5
Severity: minor Keywords:
Cc:

Description

Hello Everyone,


I would like to report the following two issues that I encountered when
installing SoGE this week.


1) When using the GUI to install the qmaster, you cannot select
'classic' as the spooling method or the 'select hosts' page will be blank.

2) When installing dbwriter with a postgresql backend the startup
script fails when running default/common/sgedbwriter.


For 1) I am not sure what is wrong, if you go back and select Berkeleydb and
go forward, it's fine. The doesn't seem to be a way to get local spooling
installed through the SoGE GUI (OGS's GUI works). I had to install the
qmaster via inst_sge first, then I could install the execution hosts (with
local spooling) through the GUI.

Here is the error that I get in the term that launches it:

Starting Installer ...

java.lang.NullPointerException?

at java.util.Hashtable.put(Hashtable.java:542)

at

java.util.Properties.setProperty(Properties.java:161)

at

com.izforge.izpack.installer.AutomatedInstallData?.setVariable(Unknown
Source)

at

com.sun.grid.installer.gui.HostPanel?.panelActivate(HostPanel?.java:694)

at

com.izforge.izpack.installer.InstallerFrame?.switchPanel(Unknown Source)

at

com.izforge.izpack.installer.InstallerFrame?.navigateNext(Unknown Source)

at

com.izforge.izpack.installer.InstallerFrame?.navigateNext(Unknown Source)

at

com.izforge.izpack.installer.InstallerFrame?$NavigationHandler?.actionPerforme
d(Unknown Source)

at

javax.swing.AbstractButton?.fireActionPerformed(AbstractButton?.java:2018)

at

javax.swing.AbstractButton?$Handler.actionPerformed(AbstractButton?.java:2341)

at

javax.swing.DefaultButtonModel?.fireActionPerformed(DefaultButtonModel?.java:4
02)

at

javax.swing.DefaultButtonModel?.setPressed(DefaultButtonModel?.java:259)

at

javax.swing.plaf.basic.BasicButtonListener?.mouseReleased(BasicButtonListener?
.java:252)

at

java.awt.Component.processMouseEvent(Component.java:6505)

at

javax.swing.JComponent.processMouseEvent(JComponent.java:3312)

at

java.awt.Component.processEvent(Component.java:6270)

at

java.awt.Container.processEvent(Container.java:2229)

at

java.awt.Component.dispatchEventImpl(Component.java:4861)

at

java.awt.Container.dispatchEventImpl(Container.java:2287)

at

java.awt.Component.dispatchEvent(Component.java:4687)

at

java.awt.LightweightDispatcher?.retargetMouseEvent(Container.java:4832)

at

java.awt.LightweightDispatcher?.processMouseEvent(Container.java:4492)

at

java.awt.LightweightDispatcher?.dispatchEvent(Container.java:4422)

at

java.awt.Container.dispatchEventImpl(Container.java:2273)

at

java.awt.Window.dispatchEventImpl(Window.java:2719)

at

java.awt.Component.dispatchEvent(Component.java:4687)

at

java.awt.EventQueue?.dispatchEventImpl(EventQueue?.java:735)

at

java.awt.EventQueue?.access$200(EventQueue?.java:103)

at java.awt.EventQueue?$3.run(EventQueue?.java:694)

at java.awt.EventQueue?$3.run(EventQueue?.java:692)

at

java.security.AccessController?.doPrivileged(Native Method)

at

java.security.ProtectionDomain?$1.doIntersectionPrivilege(ProtectionDomain?.ja
va:76)

at

java.security.ProtectionDomain?$1.doIntersectionPrivilege(ProtectionDomain?.ja
va:87)

at java.awt.EventQueue?$4.run(EventQueue?.java:708)

at java.awt.EventQueue?$4.run(EventQueue?.java:706)

at

java.security.AccessController?.doPrivileged(Native Method)

at

java.security.ProtectionDomain?$1.doIntersectionPrivilege(ProtectionDomain?.ja
va:76)

at

java.awt.EventQueue?.dispatchEvent(EventQueue?.java:705)

at

java.awt.EventDispatchThread?.pumpOneEventForFilters(EventDispatchThread?.java
:242)

at

java.awt.EventDispatchThread?.pumpEventsForFilter(EventDispatchThread?.java:16
1)

at

java.awt.EventDispatchThread?.pumpEventsForHierarchy(EventDispatchThread?.java
:150)

at

java.awt.EventDispatchThread?.pumpEvents(EventDispatchThread?.java:146)

at

java.awt.EventDispatchThread?.pumpEvents(EventDispatchThread?.java:138)

at

java.awt.EventDispatchThread?.run(EventDispatchThread?.java:91)


For 2) I believe the problem is the placement of two semicolons in the
template file "util/sgedbwriter_template" as follows:

Line 554

  • [ -f /var/lock/subsys/sgedbwriter ] && rm -f

/var/lock/subsys/sgedbwriter;;

+ [ -f /var/lock/subsys/sgedbwriter ] && rm -f
/var/lock/subsys/sgedbwriter

+ ;;

This seems to have fixed the issue for me and I was able to install the
dbwriter.


Some information about my setup:

Systems:

5 x Haswell 4770k with 32GB RAM

CentOS 6.4 (64bit) with X11

Sons of Grid Engine 8.1.5 RPMs and tars taken directly from site.

SGE_ROOT is on an NFSv3 share on a separate server (hence the local
spooling).


Thanks,

-Chris

Change History (3)

comment:1 Changed 6 years ago by dlove

Chris Tobey <tobeychris@…> writes:

Hello Everyone,


I would like to report the following two issues that I encountered when
installing SoGE this week.


1) When using the GUI to install the qmaster, you cannot select
'classic' as the spooling method or the 'select hosts' page will be blank.

2) When installing dbwriter with a postgresql backend the startup
script fails when running default/common/sgedbwriter.

Thanks. I'm puzzled because they look like things which were tested.

I expect 1) is due to removing confusing items with remote BDB not being
supported, but I thought I'd gone through a classic spooling
installation. You can probably use older versions of both, if it helps,
although the name of the .jar file for the postgres interface has
changed in recent postgres versions.

comment:2 Changed 6 years ago by dlove

comment:3 Changed 6 years ago by Dave Love <d.love@…>

  • Owner set to Dave Love <d.love@…>
  • Resolution set to fixed
  • Status changed from new to closed

In 4635/sge:

Fix #1478: mod GUI installer for classic spooling, removing more BDB server
Thanks to Chris Tobey
Probably all the BDB server code should be stripped out.

Note: See TracTickets for help on using tickets.