Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1541 closed defect (invalid)

Allow using libmotif instead of lesstif2

Reported by: agrothberg Owned by:
Priority: normal Milestone:
Component: sge Version: 8.1.8
Severity: minor Keywords:
Cc:

Description

lesstif2 is no longer available in Ubuntu (starting at 14.04 LTS or earlier):
https://answers.launchpad.net/ubuntu/+source/lesstif2/+question/239338

The install should accept libmotif (assuming that package is an acceptable substitute).

See: http://arc.liv.ac.uk/pipermail/sge-bugs/2013-November/000648.html

Attachments (1)

untitled-part.pgp (819 bytes) - added by w.hay@… 4 years ago.
Added by email2trac

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 years ago by dlove

lesstif2 is no longer available in Ubuntu (starting at 14.04 LTS or
earlier):
https://answers.launchpad.net/ubuntu/+source/lesstif2/+question/239338

The install should accept libmotif (assuming that package is an acceptable
substitute).

How does it fail for you and in which Ubuntu? The control file has

motif-dev | lesstif2-dev | libmotif-dev

comment:2 Changed 4 years ago by agrothberg

I was testing with the newest published deb files (8.1.8). And they did not
specify all of those dependency options.

On Sun, Jul 19, 2015, 06:46 SGE <sge-bugs@…> wrote:

#1541: Allow using libmotif instead of lesstif2


Reporter: agrothberg | Owner:

Type: defect | Status: new

Priority: normal | Milestone:

Component: sge | Version: 8.1.8

Severity: minor | Resolution:
Keywords: |


Comment (by dlove):

lesstif2 is no longer available in Ubuntu (starting at 14.04 LTS or
earlier):
https://answers.launchpad.net/ubuntu/+source/lesstif2/+question/239338

The install should accept libmotif (assuming that package is an

acceptable

substitute).

How does it fail for you and in which Ubuntu? The control file has

motif-dev | lesstif2-dev | libmotif-dev

--
Ticket URL: <https://arc.liv.ac.uk/trac/SGE/ticket/1541#comment:1>
SGE <https://arc.liv.ac.uk/trac/SGE>
Son of Grid Engine: Community continuation of work on Grid Engine

comment:3 Changed 4 years ago by w.hay@…

On Sun, 19 Jul 2015 13:50:50 +0000
Alex Rothberg <agrothberg@…> wrote:

I was testing with the newest published deb files (8.1.8). And they
did not specify all of those dependency options.

This looks like source/binary issue. The source package can be built
against any one of motif-dev, lesstif2-dev or libmotif-dev however once
built it can only use the binary counterpart of the package it was built
against. This is reflected in the dependencies of the package. It
looks like the binary packages Dave supplies were built against
lesstif2-dev and therefore depend on lesstif2.

The immediate solution is to rebuild the source packages on the
platform you actually want to use.

I suspect the real question is whether to build the distributed binary
packages against motif or lesstif.
Given that:
1.Lesstif only exists to be an open source/free software clone of motif
2.Motif is now available under LGPL same as Lesstif.
3.Lesstif website is dead and according to Wikipedia Lesstif itself
hasn't been updated since 2009.

It looks like building against motif has more of a future than building
against lesstif. I doubt there are many debian derived distros left
that only supply lesstif and not motif.

On Sun, Jul 19, 2015, 06:46 SGE
<sge-bugs@…<mailto:sge-bugs@…>> wrote:
#1541: Allow using libmotif instead of lesstif2


| Owner: Type: defect | Status: new

Priority: normal | Milestone:

Component: sge | Version: 8.1.8

Severity: minor | Resolution:
Keywords: |


Comment (by dlove):

lesstif2 is no longer available in Ubuntu (starting at 14.04 LTS

or earlier):

https://answers.launchpad.net/ubuntu/+source/lesstif2/+question/239338

The install should accept libmotif (assuming that package is an

acceptable

substitute).

How does it fail for you and in which Ubuntu? The control file has

motif-dev | lesstif2-dev | libmotif-dev

--
Ticket URL: <https://arc.liv.ac.uk/trac/SGE/ticket/1541#comment:1>
SGE <https://arc.liv.ac.uk/trac/SGE>
Son of Grid Engine: Community continuation of work on Grid Engine

untitled-part.pgp

Changed 4 years ago by w.hay@…

Added by email2trac

comment:5 Changed 4 years ago by dlove

  • Resolution set to invalid
  • Status changed from new to closed

I was testing with the newest published deb files (8.1.8). And they did
not
specify all of those dependency options.

The .deb files obviously don't specify the build recipe. If you want to
run on a system that doesn't satisfy the dependencies, you have to build
from the package source. The readme says the binaries were built on
what's now Debian oldstable.

comment:6 Changed 4 years ago by agrothberg

Why not leave this as an open ticket to publish future debs built against libmotif?

Note: See TracTickets for help on using tickets.