Opened 4 years ago

Closed 4 years ago

#1544 closed defect (wontfix)

FTBFS Scientific Linux 5/RHEL5

Reported by: wish Owned by:
Priority: normal Milestone:
Component: sge Version: current development
Severity: minor Keywords:
Cc:

Description

bleeding edge from DARCS doesn't build on SL5 and presumably RHEL5 bombs out with the following message:
configure.ac:14: error: possibly undefined macro: AC_USE_SYSTEM_EXTENSIONS

If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.

autoreconf: /usr/bin/autoconf failed with exit status: 1
error: Bad exit status from /var/tmp/rpm-tmp.3933 (%build)

RPM build errors:

Bad exit status from /var/tmp/rpm-tmp.3933 (%build)

The root cause is presumably that SL5 only provides autoconf-2.59 while the macro complained about is defined in version 2.61 AIUI.

If I understand Darcs annotate correctly this was introduced by the following patch:

Sun Apr 6 18:19:24 BST 2014 Dave Love <d.love@…>

  • Use large file macros, not ...64 functions

Change History (3)

comment:1 Changed 4 years ago by wish

The following bug is what makes me think it is related to the autoconf version:
https://bugzilla.redhat.com/show_bug.cgi?id=228808

comment:2 Changed 4 years ago by dlove

  • Resolution set to wontfix

An actual distribution would contain a built configure (via a darcs
hook), but I haven't tested the result on EPEL5. I assume the result
will work, but let me know if not. (I provided an autoconf268 (?)
package for EPEL6, but that won't build on EPEL5 as far as I remember.)

comment:3 Changed 4 years ago by dlove

  • Status changed from new to closed
Note: See TracTickets for help on using tickets.