Opened 4 years ago

Last modified 3 years ago

#1547 reopened defect

qconf -su <ACL> on non admin/submit host gives misleading message

Reported by: wish Owned by: Dave Love <d.love@…>
Priority: normal Milestone:
Component: sge Version: 8.1.8
Severity: minor Keywords:
Cc:

Description

If you use qconf -su <ACL> on a host that is neither an admin or submit host the error message misleadingly claims the ACL does not exist rather than reporting that the command is being run in an inappropriate place:

denied: access list "AllUsers?" does not exist

This is not consistent with what happens with qconf -sprj

Change History (5)

comment:1 Changed 4 years ago by wish

The question mark in the above error message wasn't visible when I cut and pasted it but appears if I click preview

comment:2 Changed 4 years ago by dlove

The question mark in the above error message wasn't visible when I cut and
pasted it but appears if I click preview

It's a wiki-ism -- don't worry about it.

For what it's worth, the bug applies to various options apart from -su.
I suspect it's best to check the host before processing options other
than -help.

comment:3 Changed 4 years ago by Dave Love <d.love@…>

  • Owner set to Dave Love <d.love@…>
  • Resolution set to fixed
  • Status changed from new to closed

In 4835/sge:

Fix #1547: Check for admin host initially, fixing missing checks

comment:4 Changed 3 years ago by Dave Love <d.love@…>

In 4912/sge:

Fix #1576: Revert bogus change "Fix #1547: ..."
The original bug needs addressing differently.

comment:5 Changed 3 years ago by dlove

  • Resolution fixed deleted
  • Status changed from closed to reopened

Needs to be fixed properly after [4912/sge]

Note: See TracTickets for help on using tickets.