Opened 3 years ago

Closed 3 years ago

#1585 closed defect (worksforme)

[javac] warning: [options] bootstrap class path not set in conjunction with -source 1.5

Reported by: anshuhim20@… Owned by:
Priority: normal Milestone:
Component: sge Version: 8.1.9
Severity: minor Keywords:
Cc:

Description

Hello SGE Experts,

I have unzipped sge 8.1.9.tar file and coppied into my /home
went to ...../source folder
done ./scripts/bootstrap.sh
Status: "Build successful.....Run ./aimk"
after ./aimk
warning [javac] warning: [options] bootstrap class path not set in
conjunction with -source 1.5
with multiple errors like
1.error: package junit.framework does not exist

  1. error: cannot find symbol [java] [javac] public static Test

suite() {
3.fail("Unable to modify user qtask file")
4.fail("Unable to create job script");
...etc.

Kindly advise the needful

Looking forward to hear from you

Regards

--
Himanshu Joshi
M.Tech. Cognitive & Neuroscience.
Ph.D Scholar,
Department of Psychiatry
NIMHANS, Bangalore
Publications
<https://scholar.google.co.in/citations?hl=en&user=OspDsGUAAAAJ&view_op=list_works&gmla=AJsN-F4EvpCnES94r26jSpcDQFnN_-rSpEtp0PNdwObxCjniNpjkL55yPooOzK6epx6bHLvPuwJ2LIL3Wgkvxn4xeZXy5Wh0NpiR4E_Ebq88a1jaCS4r5q14b_4jCaeeDct8aeK15Bxr>
Multimodal Brain Image Analysis Laboratory
<http://mbial.weebly.com/himanshu-joshi.html>

Change History (5)

comment:1 Changed 3 years ago by dlove

  • Resolution set to worksforme
  • Status changed from new to closed

It looks as if you don't have junit installed somewhere that the
compiler can find it. There are notes on the build requirements in
source/README.build. (If you don't need the Java bits, you can use
./aimk -no-java.)

comment:2 Changed 3 years ago by anshuhim20@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Thanks,
what if I would like to install with java option
Is there a way to install junit...
I had tried with ./aimk -no java command also, the following error is coming

[root@localhost source]# ./aimk -no-java
Building in directory: /home/JPJ/SGE/sge-8.1.8/source
making in LINUXAMD64/ for LINUXAMD64 at host localhost.localdomain
_C_O_R_ES_Y_S_T_E_M_
_Q_M_O_N
cc -c -DSGE_ARCH_STRING=\"lx-amd64\" -O2 -Wstrict-prototypes -DUSE_POLL
-DLINUX -DLINUXAMD64 -DLINUXAMD64 -D_GNU_SOURCE -DGETHOSTBYNAME_R6
-DGETHOSTBYADDR_R8 -DTARGET_64BIT -DSGE_PQS_API -DSPOOLING_dynamic
-DSECURE -DHAVE_HWLOC=1 -DCOMPILE_DC -DSGE_COMPILE_WITH_GETTEXT
-DSGE_NO_USERMAPPING -I../Xmt310 -Wno-strict-prototypes -Wno-error
-DXMT_HAS_STRERROR -I../3rdparty/qmon/Xmt310 -I../3rdparty/qmon/Xbae
-I../3rdparty/qmon/iconlist -I../3rdparty/qmon/ltree
-I../3rdparty/qmon/outline -I../3rdparty/qmon/rowcol
-I../3rdparty/qmon/spinbox -I../clients/qmon -I../3rdparty/qmon/tab
-I/usr/include/freetype2 -fPIC ../Xmt310/Xmt/All.c
In file included from ../Xmt310/Xmt/All.c:23:0:
../Xmt310/Xmt/Xmt.h:56:19: fatal error: Xm/Xm?.h: No such file or directory

#include <Xm/Xm?.h>


compilation terminated.
make: * [All.o] Error 1
not done

Looking forward to hear from you
Regards

On Mon, Oct 10, 2016 at 5:31 PM, SGE <sge-bugs@…> wrote:

#1585: [javac] warning: [options] bootstrap class path not set in
conjunction with
-source 1.5


Reporter: anshuhim20@… | Owner:

Type: defect | Status: closed

Priority: normal | Milestone:

Component: sge | Version: 8.1.9

Severity: minor | Resolution: worksforme
Keywords: |


Changes (by dlove):

  • status: new => closed
  • resolution: => worksforme

Comment:

It looks as if you don't have junit installed somewhere that the
compiler can find it. There are notes on the build requirements in
source/README.build. (If you don't need the Java bits, you can use
./aimk -no-java.)

--
Ticket URL: <https://arc.liv.ac.uk/trac/SGE/ticket/1585#comment:1>
SGE <https://arc.liv.ac.uk/trac/SGE>
Son of Grid Engine: Community continuation of work on Grid Engine

--
Himanshu Joshi
M.Tech. Cognitive & Neuroscience.
Ph.D Scholar,
Department of Psychiatry
NIMHANS, Bangalore
Publications
<https://scholar.google.co.in/citations?hl=en&user=OspDsGUAAAAJ&view_op=list_works&gmla=AJsN-F4EvpCnES94r26jSpcDQFnN_-rSpEtp0PNdwObxCjniNpjkL55yPooOzK6epx6bHLvPuwJ2LIL3Wgkvxn4xeZXy5Wh0NpiR4E_Ebq88a1jaCS4r5q14b_4jCaeeDct8aeK15Bxr>
Multimodal Brain Image Analysis Laboratory
<http://mbial.weebly.com/himanshu-joshi.html>

comment:3 Changed 3 years ago by wish

  • Resolution set to worksforme
  • Status changed from reopened to closed

This sort of question is best asked on users@… or sge-discuss@….
How you install junit will depend on your OS and prefernces. The Xm.h comes from openmotif
or lesstif.

comment:4 Changed 3 years ago by dlove

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Please don't reopen this -- it's not a bug if you don't have the build
dependencies listed in the README (and the rpm and dpkg source files for
several GNU/Linux distributions).

comment:5 Changed 3 years ago by dlove

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.