Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1588 closed defect (fixed)

compiling SGE for CentOS7

Reported by: angela.sommer Owned by: Dave Love <d.love@…>
Priority: normal Milestone:
Component: sge Version: 8.1.9
Severity: minor Keywords:
Cc:

Description

./aimk -spool-classic -spool-targets

stops with error:

./libspoolloader.a(sge_spooling_loader.o): In function `spool_create_dynamic_context':
sge_spooling_loader.c:(.text+0x45): undefined reference to `spool_dynamic_create_context'
collect2: error: ld returned 1 exit status
make: * [test_performance] Error 1

Could you help me with that?
best reagrds
Angela

Change History (4)

comment:1 Changed 3 years ago by wish

This sort of question is probably best dealt with on users@…. A quick google suggests that this message can be caused by failure to clean up object files after a previous (possibly failed) build.

comment:2 in reply to: ↑ description Changed 3 years ago by dlove

Replying to angela.sommer:

./aimk -spool-classic -spool-targets

I don't know why that fails, but why do you particularly want to do it?
What's wrong with the build procedure for the rpms?

comment:3 Changed 3 years ago by Dave Love <d.love@…>

  • Owner set to Dave Love <d.love@…>
  • Resolution set to fixed
  • Status changed from new to closed

In 4936/sge:

Fix #1588: Don't fail with aimk -spool-classic

comment:4 Changed 3 years ago by Dave Love <d.love@…>

In 4936/sge:

Fix #1588: Don't fail with aimk -spool-classic

Note: See TracTickets for help on using tickets.