Opened 13 years ago

Closed 6 years ago

#162 closed defect (fixed)

IZ963: Can't run HPUX binaries

Reported by: jeffbeadles Owned by:
Priority: highest Milestone:
Component: sge Version: 6.0beta
Severity: minor Keywords: HP HP-UX install
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=963]

        Issue #:      963              Platform:     HP        Reporter: jeffbeadles (jeffbeadles)
       Component:     gridengine          OS:        HP-UX
     Subcomponent:    install          Version:      6.0beta      CC:    None defined
        Status:       VERIFIED         Priority:     P1
      Resolution:     FIXED           Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    andy (andy)
      QA Contact:     dom
          URL:
       * Summary:     Can't run HPUX binaries
   Status whiteboard:
      Attachments:

     Issue 963 blocks:
   Votes for issue 963:


   Opened: Thu Apr 8 09:39:00 -0700 2004 
------------------------


I mailed this to the dev list, but wanted to
make sure it's tracked and will be fixed in the
next release.

When trying to run install_execd;

"
./inst_sge[131]: 13757 Abort
/usr/lib/dld.sl: Can't open shared
library: /vol2/tools/SW/openssl-
0.9.7c/hp11/lib/libcrypto.sl.0.9.7
/usr/lib/dld.sl: No such file or directory
./inst_sge[57]: 13776 Abort(coredump)

Command failed: ./bin/hp11/qconf -sh

Probably a permission problem. Please check file
access permissions.
Check read/write permission. Check if SGE
daemons are running.
"

With a message like that, I know that it's not a
permission problem, but rather a missing shared
library.  So;

$ chatr bin/hp11/qconf
bin/hp11/qconf:
         shared executable
         shared library dynamic path search:
             SHLIB_PATH     disabled  second
             embedded path  disabled  first  Not
Defined
         shared library list:
             dynamic   /vol2/tools/SW/openssl-
0.9.7c/hp11/lib/libcrypto.sl.0.9.7
             dynamic   /usr/lib/libnsl.1
             dynamic   /usr/lib/libm.2
             dynamic   /usr/lib/libpthread.1
             dynamic   /usr/lib/libc.2
         shared library binding:
             deferred
         global hash table disabled
         plabel caching disabled
         global hash array size:1103
         global hash array nbuckets:3
         shared vtable support disabled
         static branch prediction disabled
         executable from stack: D (default)
         kernel assisted branch prediction
enabled
         lazy swap allocation disabled
         text segment locking disabled
         data segment locking disabled
         third quadrant private data space
disabled
         fourth quadrant private data space
disabled
         third quadrant global data space
disabled
         data page size: D (default)
         instruction page size: D (default)
         nulptr references disabled
         shared library private mapping disabled
         shared library text merging disabled

The problem is the line that reads;
"             SHLIB_PATH     disabled  second"

This says to not look in SHLIB_PATH for the
shared libraries.

To fix this, change the HP makefile/build rules
and add a "+s" to the link arguments for all of
the executables that need things from
$SHLIB_PATH.

It can also be modified post-build by running $
chatr +s enable bin/hp11/*

(I've verified that this works, at least on HPUX
11.11)

Regards,
        -Jeff

   ------- Additional comments from andy Mon Apr 19 05:01:01 -0700 2004 -------
Fixed in Beta2. Need feedback from user if it works

   ------- Additional comments from andy Mon Apr 19 05:02:17 -0700 2004 -------
.

   ------- Additional comments from jeffbeadles Tue Jul 13 07:31:50 -0700 2004 -------
Works great in the 6.0 "production" release.  Thanks Andy!

Change History (1)

comment:1 Changed 6 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.