#1630 closed defect (fixed)

qmake fails to build with glibc 2.27

Reported by: opoplawski Owned by:
Priority: normal Milestone:
Component: sge Version: 8.1.9
Severity: minor Keywords:
Cc:

Description

See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891373

The problem is that the glibc 2.27 slightly changed its internal glob
implementation. gridengine uses an internal copy of make, which detects
that it doesn't support the new interface and switch to its internal
implementation which is slightly broken.

Attachments (1)

sge-qmake-glob-glibc227.patch (2.2 KB) - added by opoplawski 16 months ago.
patch for qmake

Download all attachments as: .zip

Change History (3)

Changed 16 months ago by opoplawski

patch for qmake

comment:2 Changed 16 months ago by dlove

The distribution copr has several patches to build on f28, at least, but
eggert's change is doubtless the one to use.

comment:3 Changed 16 months ago by admin

  • Resolution set to fixed
  • Status changed from new to closed

In 4969/sge:

Fix #1630: Use fix from gnulib for glob in qmake with recent glibc

Note: See TracTickets for help on using tickets.