Opened 16 years ago

Closed 8 years ago

#166 closed enhancement (duplicate)

IZ1010: Job array lack means to get email notification for the total array

Reported by: andreas Owned by:
Priority: normal Milestone:
Component: sge Version: 6.0beta2
Severity: minor Keywords: qmaster
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=1010]

        Issue #:      1010             Platform:     All           Reporter: andreas (andreas)
       Component:     gridengine          OS:        All
     Subcomponent:    qmaster          Version:      6.0beta2         CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     ernst
          URL:
       * Summary:     Job array lack means to get email notification for the total array
   Status whiteboard:
      Attachments:

     Issue 1010 blocks:
   Votes for issue 1010:


   Opened: Fri Apr 30 05:15:00 -0700 2004 
------------------------


DESCRIPTION:
There is a need for a means to sumit job arrays
in a way allowing email notifications be requested
for the total job.

Workaround:
The following solution helps only in the last
phase of the e-mail
delivery: from the e-mail daemon to the inbox. It
doesn't reduce the
number of e-mails generated by SGE nor the number
of messages that
have to pass through any intermediate e-mail daemons.

So, the solution is to use procmail for e-mail
filtering. procmail is
set to run from .forward and is handed the message
from the
daemon instead of writting it into the inbox.
Procmail has duplicate
mails detection capabilities, explained in 'man
procmailex'. You can
set it to check for the jobid and deliver only one
message per jobid.
procmail keeps a small cache of already seen
matching sequences and so
if the tasks take too long to complete while many
other jobs finish,
it might allow more than one message per jobid;
however the cache size
is configurable, so you can play with it to obtain
the best results.

   ------- Additional comments from sgrell Mon Dec 12 02:55:45 -0700 2005 -------
Changed the Subcomponent.

Stephan

Change History (1)

comment:1 Changed 8 years ago by dlove

  • Resolution set to duplicate
  • Severity set to minor
  • Status changed from new to closed

Duplicate of #300

Note: See TracTickets for help on using tickets.