Opened 12 years ago

Closed 5 years ago

#207 closed enhancement (duplicate)

IZ1321: change default value for pe attribs start/stop_proc_args

Reported by: joga Owned by:
Priority: high Milestone:
Component: sge Version: current
Severity: minor Keywords: clients
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=1321]

        Issue #:      1321             Platform:     All           Reporter: joga (joga)
       Component:     gridengine          OS:        All
     Subcomponent:    clients          Version:      current          CC:    None defined
        Status:       NEW              Priority:     P2
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     roland
          URL:
       * Summary:     change default value for pe attribs start/stop_proc_args
   Status whiteboard:
      Attachments:

     Issue 1321 blocks:
   Votes for issue 1321:


   Opened: Mon Nov 8 08:17:00 -0700 2004 
------------------------


The default value for the start_proc_args and
stop_proc_args of parallel environment currently is
/bin/true

We should better use NONE as default value instead, as
- /bin/true isn't available on all platforms (darwin)
- it implies starting a binary during the startup
of a parallel job that has no effect on the job itself

   ------- Additional comments from sgrell Mon Dec 12 02:42:08 -0700 2005 -------
Changed subcomponent.

Stephan

   ------- Additional comments from joga Tue May 16 23:56:47 -0700 2006 -------
Raising priority.

/bin/true is not available on all platforms (e.g. on darwin, it is /usr/bin/true).
Jobs submitted into a parallel environment created with the default settings
will fail.

Change History (1)

comment:1 Changed 5 years ago by dlove

  • Resolution set to duplicate
  • Severity set to minor
  • Status changed from new to closed

Duplicate of #1289

Note: See TracTickets for help on using tickets.