Opened 14 years ago

Closed 8 years ago

#266 closed defect (fixed)

IZ1736: sge_ca -usercert never exits

Reported by: agrajag Owned by:
Priority: normal Milestone:
Component: sge Version: 6.0u4
Severity: minor Keywords: Linux install
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=1736]

        Issue #:      1736             Platform:     All      Reporter: agrajag (agrajag)
       Component:     gridengine          OS:        Linux
     Subcomponent:    install          Version:      6.0u4       CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     dom
          URL:
       * Summary:     sge_ca -usercert never exits
   Status whiteboard:
      Attachments:

     Issue 1736 blocks:
   Votes for issue 1736:


   Opened: Wed Aug 3 12:26:00 -0700 2005 
------------------------


If you call sge_ca with the '-usercert' command, it then tried to call 'openssl
rand -rand /dev/urandom -out /some/file 2048'.  However, the openssl command it
tries to call will never exit, thus the sge_ca command will never exit, since it
will never finish reading from /dev/urandom.

Please see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165036 for more
info on why the openssl command will not exit.


This behavior in sge_ca is new in 6.0u4.  It worked fine in 6.0u3.

   ------- Additional comments from sgrell Tue Dec 6 08:11:43 -0700 2005 -------
Changed the Subcomponent.

Stephan

   ------- Additional comments from roland Mon Feb 13 01:38:12 -0700 2006 -------
changed subcomponent

Change History (1)

comment:1 Changed 8 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.