Opened 14 years ago

Closed 7 years ago

#298 closed defect (fixed)

IZ1894: qstat incorrectly reports job scheduling failure

Reported by: templedf Owned by:
Priority: low Milestone:
Component: sge Version: current
Severity: minor Keywords: scheduling
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=1894]

        Issue #:      1894             Platform:     All       Reporter: templedf (templedf)
       Component:     gridengine          OS:        All
     Subcomponent:    scheduling       Version:      current      CC:    None defined
        Status:       NEW              Priority:     P4
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    sgrell (sgrell)
      QA Contact:     andreas
          URL:
       * Summary:     qstat incorrectly reports job scheduling failure
   Status whiteboard:
      Attachments:

     Issue 1894 blocks:
   Votes for issue 1894:


   Opened: Tue Nov 15 14:23:00 -0700 2005 
------------------------


If I submit a job with an unfulfillable resource request, I get the following:

% qsub -l arch=sol-sparc6 /tmp/dant/examples/jobs/sleeper.sh
Your job 6 ("Sleeper") has been submitted.
% qstat -j 6
==============================================================
job_number:                 6
...
scheduling info:            (-l arch=sol-sparc6) cannot run globally because
                            (-l arch=sol-sparc6) cannot run at host
"balrog.germany.sun.com" because it offers only hl:arch=sol-sparc64
                            (-l arch=sol-sparc6) cannot run at host "balin"
because it offers only hl:arch=sol-sparc64


First of all, should there even be an message that the job cannot be run
globally?  Secondly, the message is incomplete: cannot be run because why?

I have am seeing this problem in the Maintrunk.  I have not tested it in any of
the release branches.

   ------- Additional comments from roland Wed Nov 16 01:21:30 -0700 2005 -------
For correct subcomponent tracking I've moved this bug to "scheduling" because
the scheduler is responsible for the scheduling info. The qstat command only
prints out the messages reported by the scheduler.

I assume you want to say with "should there even be an message that the job
cannot be run globally" qsub should deny the job at submittion time. This is
wrong. Per default qsub accepts all jobs but as in this case they will never be
scheduled. You can force the consumable verification at submittion time with the
"-w" switch.


   ------- Additional comments from templedf Wed Nov 16 12:46:15 -0700 2005 -------
I meant that jobs don't run "globally."  They run on hosts.  Of course the job
cannot be run "globally."  It's not possible!
Of course, I could be wrong about what the message is supposed to mean...

   ------- Additional comments from sgrell Tue Nov 22 02:22:10 -0700 2005 -------
I will look into it.

Stephan

   ------- Additional comments from sgrell Mon Dec 5 02:01:43 -0700 2005 -------
*** Issue 1817 has been marked as a duplicate of this issue. ***

Change History (1)

comment:1 Changed 7 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed

SG-2005-11-22-0

Note: See TracTickets for help on using tickets.