Opened 17 years ago

Last modified 9 years ago

#34 new enhancement

IZ244: Load sensor problems are difficult to diagnose

Reported by: andy Owned by:
Priority: normal Milestone:
Component: sge Version: 5.3
Severity: Keywords: execution
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=244]

        Issue #:      244              Platform:     All           Reporter: andy (andy)
       Component:     gridengine          OS:        All
     Subcomponent:    execution        Version:      5.3              CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    pollinger (pollinger)
      QA Contact:     pollinger
          URL:
       * Summary:     Load sensor problems are difficult to diagnose
   Status whiteboard:
      Attachments:

     Issue 244 blocks:
   Votes for issue 244:


   Opened: Fri May 3 03:29:00 -0700 2002 
------------------------


There are a couple of areas where (external) load
sensor value logging might
be improved:

   - better logging in execd if there are problems
reading the load sensor
     output
   - having the possibility to enable logging of
the raw data in a temporary
     file in the execd.
   - logging of output which goes to standard
error of the load sensor
     script
   - better logging in qmaster if execd reports
complex attributes which are
     unknown or which contain unparsable values
   - having more and better possibilites in
qstat/qhost to print load values
     in all their forms (raw, scaled, consumed,
load adjusted)
   - extending our logging to enable logging of
"layers" instead of
     syslog-like hierarchies, e.g.:

      log_level log_warning log_load log_job

   ------- Additional comments from joga Thu Jan 29 07:26:17 -0700 2004 -------
For the improvment item "logging of output which goes to standard
error of the load sensor" see also Issue 632 describing a long term fix.

   ------- Additional comments from pollinger Fri Dec 9 10:12:20 -0700 2005 -------
Changed subcomponent

   ------- Additional comments from opoplawski Tue Dec 15 13:31:39 -0700 2009 -------
Is this still something to shoot for?  I'm not having much luck debugging my load sensor issue on Windows.  Perhaps time to update version?

Change History (0)

Note: See TracTickets for help on using tickets.