Opened 13 years ago

Closed 7 years ago

#403 closed defect (fixed)

IZ2191: qstat -s hX filtering is broken on darwin

Reported by: roland Owned by:
Priority: normal Milestone:
Component: sge Version: 6.1beta
Severity: minor Keywords: Sun clients
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2191]

        Issue #:      2191             Platform:     Sun       Reporter: roland (roland)
       Component:     gridengine          OS:        All
     Subcomponent:    clients          Version:      6.1beta      CC:    None defined
        Status:       STARTED          Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: 6.1u1
      Assigned to:    joga (joga)
      QA Contact:     roland
          URL:
       * Summary:     qstat -s hX filtering is broken on darwin
   Status whiteboard:
      Attachments:

     Issue 2191 blocks:
   Votes for issue 2191:


   Opened: Fri Feb 16 03:17:00 -0700 2007 
------------------------


The qstat_option_s test fails on darwin because the qstat filtering is broken.
Instead of showing only jobs in specific hold state all hold state jobs are shown.

The issue exists only on darwin-x86 and darwin-ppc. I've tested it also with
hp11-64, sol-sparc64, lx24-ia64 and they work fine.

   ------- Additional comments from joga Fri Jun 22 05:00:31 -0700 2007 -------
I take it.

   ------- Additional comments from joga Fri Jun 22 05:01:23 -0700 2007 -------
Can reproduce the issue on darwin-ppc, both running qstat manually and through
testsuite using the testsuite option preferred_archs darwin-ppc.

Can not reproduce the issue on darwin-x86.
*** (#1 of 2): 2007-06-22 09:43:36 CEST joachim.gabler@sun.com

It clearly looks like a compiler bug.
The bitmask used for filtering jobs is built incorrectly,
in function build_job_state_filter.

The code is needlessly complicated, but correct.
It works on all other platforms, and it works on darwin-ppc, when either a
printf is introduced in the loop over all options, or when compilation of the
module is done without optimization.

Change History (1)

comment:1 Changed 7 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed

JG-2007-06-25-0

Note: See TracTickets for help on using tickets.