Opened 12 years ago

Last modified 9 years ago

#430 new defect

IZ2259: SGE does not work if primary group is not in local files

Reported by: fallenkell Owned by:
Priority: normal Milestone:
Component: sge Version: 6.1
Severity: Keywords: Solaris kernel
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2259]

        Issue #:      2259             Platform:     All       Reporter: fallenkell (fallenkell)
       Component:     gridengine          OS:        Solaris
     Subcomponent:    kernel           Version:      6.1          CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     andreas
          URL:
       * Summary:     SGE does not work if primary group is not in local files
   Status whiteboard:
      Attachments:

     Issue 2259 blocks:
   Votes for issue 2259:


   Opened: Wed May 23 08:55:00 -0700 2007 
------------------------


This is a similar problem to issue #2249, and in fact I believe it may be the
same underlying issue. NIS groups are not properly used in the sge_group2gid
function, and according to #2249, LDAP does not seem to work either.

Version 6.1 does not work correctly unless the primary group of the user is in
the local group file on the system(s). I had to add the primary groupname and
groupid into the local /etc/group file for any grid command to work, otherwise,
the following error occurs:

%qstat
error: sge_group2gid failed for groupname users1

Where users1 is the primary group of the user issuing the command.

This problem does not exist in v6.0u5, v6.0u10, or v6.1beta2, but was introduced
in v6.1.

Change History (0)

Note: See TracTickets for help on using tickets.