Opened 11 years ago

Closed 5 years ago

#529 closed enhancement (fixed)

IZ2621: Need presubmission procedures

Reported by: andreas Owned by:
Priority: normal Milestone:
Component: sge Version: 6.2
Severity: minor Keywords: kernel
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2621]

        Issue #:      2621             Platform:     All           Reporter: andreas (andreas)
       Component:     gridengine          OS:        All
     Subcomponent:    kernel           Version:      6.2              CC:
                                                                             [_] bbarth
                                                                             [_] reuti
                                                                             [_] Remove selected CCs
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    ernst (ernst)
      QA Contact:     andreas
          URL:        http://wiki.gridengine.info/wiki/index.php/PresubmissionProcedures
       * Summary:     Need presubmission procedures
   Status whiteboard:
      Attachments:

     Issue 2621 blocks:
   Votes for issue 2621:


   Opened: Thu Jun 19 08:23:00 -0700 2008 
------------------------


There is a need for a plug-in interface that allows jobs be verified/modified in
accordance with site-specific needs:

- idea is to implement a general purpose shared library plug-in interface
- the plug-in would facilitate customized job verification/modification
- SGE would however contain only a plug-in that forks/execs/waits a script-based
plug-in
- the need for the superior (performance) shared library general purpose plug-in
interface  exists actually only for sites where raw masses of jobs float through
SGE every day
- for load-balancing a qsub/qrsh/qsh/qlogin/qmon plug-in were ideal
- for maximum of control a qmaster plug-in were ideal
- contradicting objectives (load-balancing vs. maximum of control) suggest both
qmaster and qsub/qrsh/qsh/qlogin/qmon should get a plug-in interface
- must prevent qalter can be used to bypass policy implemented via plug-ins

   ------- Additional comments from reuti Fri Jun 20 05:51:09 -0700 2008 -------
Can someome please mark http://gridengine.sunsource.net/issues/show_bug.cgi?id=2593 as a duplicate
of this. - Thx - Reuti

   ------- Additional comments from andreas Fri Jun 20 06:10:02 -0700 2008 -------
*** Issue 2593 has been marked as a duplicate of this issue. ***

   ------- Additional comments from andreas Fri Jun 20 06:38:59 -0700 2008 -------
Added URL to specification document that is in the works.

   ------- Additional comments from ernst Tue Sep 23 04:53:23 -0700 2008 -------
Today I sent a specification draft to the users mailing list (subject: job
submission verifier)

   ------- Additional comments from ernst Tue Jan 13 07:19:33 -0700 2009 -------
Script based solution is implemented and feature will be available with 6.2u2.
If performace of this solution becomes an issue we might also add support for
shared libraray JSVs easyly.

Change History (1)

comment:1 Changed 5 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.