Opened 9 years ago

Closed 6 years ago

#541 closed defect (invalid)

IZ2640: execd core dump

Reported by: andreas Owned by:
Priority: high Milestone:
Component: sge Version: 6.1AR_snapshot3_8
Severity: minor Keywords: PC Linux execution
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2640]

        Issue #:      2640             Platform:     PC                  Reporter: andreas (andreas)
       Component:     gridengine          OS:        Linux
     Subcomponent:    execution        Version:      6.1AR_snapshot3_8      CC:
                                                                                   [_] bbarth
                                                                                   [_] Remove selected CCs
        Status:       STARTED          Priority:     P2
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    pollinger (pollinger)
      QA Contact:     pollinger
          URL:
       * Summary:     execd core dump
   Status whiteboard:
      Attachments:

     Issue 2640 blocks:
   Votes for issue 2640:


   Opened: Fri Jul 4 07:49:00 -0700 2008 
------------------------


Two core dumps

$ LD_PRELOAD=/opt/sge/lib/lx24-amd64/libcore.so gdb
/opt/sge/bin/lx24-amd64/sge_execd execd.core.7420
GNU gdb Red Hat Linux (6.3.0.0-1.143.el4rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/tls/libthread_db.so.1".

Core was generated by `/opt/sge/bin/lx24-amd64/sge_execd'.
Program terminated with signal 11, Segmentation fault.

warning: .dynamic section for "/lib64/libdl.so.2" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/tls/libm.so.6" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/tls/libpthread.so.0" is not at the
expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/tls/libc.so.6" is not at the expected address

warning: .dynamic section for "/lib64/ld-linux-x86-64.so.2" is not at the
expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/libresolv.so.2" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations
Reading symbols from /opt/sge/lib/lx24-amd64/libcore.so...(no debugging symbols
found)...done.
Loaded symbols for /opt/sge/lib/lx24-amd64/libcore.so
Reading symbols from /lib64/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libdl.so.2
Reading symbols from /lib64/tls/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/tls/libm.so.6
Reading symbols from /lib64/tls/libpthread.so.0...(no debugging symbols
found)...done.
Loaded symbols for /lib64/tls/libpthread.so.0
Reading symbols from /lib64/tls/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/tls/libc.so.6
Reading symbols from /lib64/ld-linux-x86-64.so.2...
(no debugging symbols found)...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Reading symbols from /lib64/libnss_files.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_files.so.2
Reading symbols from /lib64/libnss_dns.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_dns.so.2
Reading symbols from /lib64/libresolv.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libresolv.so.2

#0  0x00000000004d97de in cl_raw_list_lock ()
(gdb) where
#0  0x00000000004d97de in cl_raw_list_lock ()
#1  0x00000000004d4bd9 in cl_commlib_app_message_queue_cleanup ()
#2  0x00000000004d3124 in cl_com_handle_service_thread ()
#3  0x00000039f7806137 in start_thread () from /lib64/tls/libpthread.so.0
#4  0x0000000000000000 in ?? ()

$ LD_PRELOAD=/opt/sge/lib/lx24-amd64/libcore.so gdb
/opt/sge/bin/lx24-amd64/sge_execd execd.core.7451
GNU gdb Red Hat Linux (6.3.0.0-1.143.el4rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/tls/libthread_db.so.1".

Core was generated by `/opt/sge/bin/lx24-amd64/sge_execd'.
Program terminated with signal 11, Segmentation fault.

warning: .dynamic section for "/lib64/libdl.so.2" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/tls/libm.so.6" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/tls/libpthread.so.0" is not at the
expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/tls/libc.so.6" is not at the expected address

warning: .dynamic section for "/lib64/ld-linux-x86-64.so.2" is not at the
expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/libresolv.so.2" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations
Reading symbols from /opt/sge/lib/lx24-amd64/libcore.so...(no debugging symbols
found)...done.
Loaded symbols for /opt/sge/lib/lx24-amd64/libcore.so
Reading symbols from /lib64/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libdl.so.2
Reading symbols from /lib64/tls/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/tls/libm.so.6
Reading symbols from /lib64/tls/libpthread.so.0...(no debugging symbols
found)...done.
Loaded symbols for /lib64/tls/libpthread.so.0
Reading symbols from /lib64/tls/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/tls/libc.so.6
Reading symbols from /lib64/ld-linux-x86-64.so.2...
(no debugging symbols found)...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Reading symbols from /lib64/libnss_files.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_files.so.2
Reading symbols from /lib64/libnss_dns.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_dns.so.2
Reading symbols from /lib64/libresolv.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libresolv.so.2

#0  0x00000000004d97de in cl_raw_list_lock ()
(gdb) where
#0  0x00000000004d97de in cl_raw_list_lock ()
#1  0x00000000004d4bd9 in cl_commlib_app_message_queue_cleanup ()
#2  0x00000000004d3124 in cl_com_handle_service_thread ()
#3  0x000000386bd06137 in start_thread () from /lib64/tls/libpthread.so.0
#4  0x0000000000000000 in ?? ()

   ------- Additional comments from andreas Fri Jul 4 08:54:02 -0700 2008 -------
Need to clarify if these stack traces are really authentic.

   ------- Additional comments from andreas Thu Jul 10 09:07:41 -0700 2008 -------
Got a slightly better stack trace:

env LD_PRELOAD=/opt/sge/lib/lx24-amd64/libcore.so gdb
/opt/sge/bin/lx24-amd64/sge_execd /share/sge/execd_spool//i155-301/core.7451
GNU gdb Red Hat Linux (6.3.0.0-1.153.el4_6.2rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/tls/libthread_db.so.1".

Core was generated by `/opt/sge/bin/lx24-amd64/sge_execd'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /opt/sge/lib/lx24-amd64/libcore.so...(no debugging symbols
found)...done.
Loaded symbols for /opt/sge/lib/lx24-amd64/libcore.so
Reading symbols from /lib64/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libdl.so.2
Reading symbols from /lib64/tls/libm.so.6...
(no debugging symbols found)...done.
Loaded symbols for /lib64/tls/libm.so.6
Reading symbols from /lib64/tls/libpthread.so.0...(no debugging symbols
found)...done.
Loaded symbols for /lib64/tls/libpthread.so.0
Reading symbols from /lib64/tls/libc.so.6...
(no debugging symbols found)...done.
Loaded symbols for /lib64/tls/libc.so.6
Reading symbols from /lib64/ld-linux-x86-64.so.2...(no debugging symbols
found)...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Reading symbols from /lib64/libnss_files.so.2...
(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_files.so.2
Reading symbols from /lib64/libnss_dns.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_dns.so.2
Reading symbols from /lib64/libresolv.so.2...
(no debugging symbols found)...done.
Loaded symbols for /lib64/libresolv.so.2
#0  0x00000000004d97de in cl_raw_list_lock ()
(gdb) where
#0  0x00000000004d97de in cl_raw_list_lock ()
#1  0x00000000004d4bd9 in cl_commlib_app_message_queue_cleanup ()
#2  0x00000000004d3124 in cl_com_handle_service_thread ()
#3  0x000000386bd06137 in start_thread () from /lib64/tls/libpthread.so.0
#4  0x000000386b0c7113 in clone () from /lib64/tls/libc.so.6

Change History (1)

comment:1 Changed 6 years ago by dlove

  • Resolution set to invalid
  • Severity set to minor
  • Status changed from new to closed

Not useful.

Note: See TracTickets for help on using tickets.