Opened 11 years ago

Closed 8 years ago

#592 closed defect (fixed)

IZ2777: Setting SHARETREE_RESERVED_USAGE affects CPU time accounting

Reported by: orlandorichards Owned by:
Priority: normal Milestone:
Component: sge Version: 6.1u4
Severity: minor Keywords: PC Linux qmaster
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2777]

        Issue #:      2777             Platform:     PC       Reporter: orlandorichards (orlandorichards)
       Component:     gridengine          OS:        Linux
     Subcomponent:    qmaster          Version:      6.1u4       CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    ernst (ernst)
      QA Contact:     ernst
          URL:
       * Summary:     Setting SHARETREE_RESERVED_USAGE affects CPU time accounting
   Status whiteboard:
      Attachments:

     Issue 2777 blocks:
   Votes for issue 2777:


   Opened: Wed Nov 5 07:16:00 -0700 2008 
------------------------


Use of the SHARETREE_RESERVED_USAGE=true flag also makes the accounting behave
as though ACCT_RESERVED_USAGE were enabled, even when it is explicitly disabled.

   ------- Additional comments from orlandorichards Wed Nov 5 07:20:03 -0700 2008 -------
Further info:
We have:

  execd_params                 SHARETREE_RESERVED_USAGE=TRUE \
                               ACCT_RESERVED_USAGE=FALSE

so would expect the CPU time to be recorded as roughly UTIME + STIME - but this
is not the case. Instead, it is always recorded as equal to (or "1" greater
than) wallclock time.

Setting SHARETREE_RESERVED_USAGE to FALSE gives the expected behaviour (CPU time
= 0, wallclock = 20 for a "sleep 20s" job).


Change History (1)

comment:1 Changed 8 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed

Can't reproduce now

Note: See TracTickets for help on using tickets.