Opened 11 years ago

Closed 7 years ago

#629 closed defect (fixed)

IZ2899: bad RQS syntax can crash/hang qmaster process

Reported by: craffi Owned by:
Priority: normal Milestone:
Component: sge Version: 6.2u1
Severity: minor Keywords: qmaster
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2899]

        Issue #:      2899             Platform:     All      Reporter: craffi (craffi)
       Component:     gridengine          OS:        All
     Subcomponent:    qmaster          Version:      6.2u1       CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: 6.2u3
      Assigned to:    ernst (ernst)
      QA Contact:     ernst
          URL:
       * Summary:     bad RQS syntax can crash/hang qmaster process
   Status whiteboard:
      Attachments:

     Issue 2899 blocks:
   Votes for issue 2899:


   Opened: Thu Jan 29 20:19:00 -0700 2009 
------------------------


Reproduce:

Make 2 project objects:

name testProject
oticket 0
fshare 0
usage NONE
acl NONE
xacl NONE

name testProject2
oticket 0
fshare 0
usage NONE
acl NONE
xacl NONE

The following BAD RQS syntax will hang or crash Grid Engine.

On Linux/x86_64 I was able to crash the qmaster process, on Mac OS X the system
seems to hang and clients will eventually see this error: "ERROR: failed
receiving gdi request response for mid=4 (got syncron message receive timeout
error)."


This will cause the problem:


{
  name         testRQS
  description  will this crash a qmaster?
  enabled      TRUE
  limit        projects !{testProject,testProject2} queues * hosts * to slots=10
}

   ------- Additional comments from crei Thu Feb 26 02:37:18 -0700 2009 -------
When I try to create the projects in current 62u2 (maintrunk) system I get the
following error message:

error: unknown attribute name "usage"
error: error reading file: "/tmp/1782-VUVTwk"
cant read project

But setting a incorrect resource quota set still can crash qmaster:

qconf -arqs
{
   name         abc
   description  will we crash the qmaster?
   enabled      TRUE
   limit        projects !{testProject,testProject2} queues * hosts * to slots=10
}
1024   7629    worker000     worker000 takes packet from priority queue.
(packet_queue->counter = 0; packet_queue->waiting = 1)
  1025   7629    worker000     GDI ADD resource quota set (host2/qconf/1)
(user1/0815/rad/10)
  1026   7629    worker000     got new resource quota set
  1027   7629    worker000     got new description
  1028   7629    worker000     got new enabled
  1029   7629    worker000     !!!!!!! sge_resolve_host: WARNING call with old
lStringT data type,
  1030   7629    worker000     !!!!!!! this data type should be replaced with
lHostT data type in
  1031   7629    worker000     !!!!!!! the future! Nevertheless, just a warning!
Function works fine!
=> crash !!!

Priority P3 is ok since you have to be manager user to setup invalid rqs!

Change History (2)

comment:1 Changed 8 years ago by dlove

fixed by [3254]

comment:2 Changed 7 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.