Opened 10 years ago

Closed 7 years ago

#655 closed defect (fixed)

IZ2978: qacct does not resolve complex shortcut names

Reported by: jf222792 Owned by:
Priority: low Milestone:
Component: sge Version: 6.0beta
Severity: minor Keywords: Sun clients
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=2978]

        Issue #:      2978             Platform:     Sun       Reporter: jf222792 (jf222792)
       Component:     gridengine          OS:        All
     Subcomponent:    clients          Version:      6.0beta      CC:    None defined
        Status:       REOPENED         Priority:     P4
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: 6.2u3
      Assigned to:    jf222792 (jf222792)
      QA Contact:     roland
          URL:
       * Summary:     qacct does not resolve complex shortcut names
   Status whiteboard:
      Attachments:

     Issue 2978 blocks:
   Votes for issue 2978:


   Opened: Mon Apr 6 02:56:00 -0700 2009 
------------------------


The qacct -l switch does not behave like for qstat or qsub. Complex Resources requested as shortcut are not resolved and thus no data is
collected.

Example:
Full complex name with usage report
% qacct -l arch=sol-amd64
Total System Usage
    WALLCLOCK         UTIME         STIME           CPU             MEMORY                 IO                IOW
================================================================================================================
           93             0             0             0              0.000              0.000              0.000

Shortcut complex name NO usage report
% qacct -l a=sol-amd64
total System Usage
    WALLCLOCK         UTIME         STIME           CPU             MEMORY                 IO                IOW
================================================================================================================

   ------- Additional comments from roland Thu May 7 07:38:13 -0700 2009 -------
qacct always parses the a complete accounting line, dups some strings (job_name, account_name ...) and then evaluates whether this line is
of interest.

The fix is:
1) Evaluate whether this line is of interest immediatly once a field (taken from strtok()) is ready. The time required to parse the
additional fields is then saved
2) Don't strdup() immediatly when a field is ready. Work on the local storage as long as possible and copy the strings only at the end when
the line is of interest

For a accounting file with 90000 entries this improved the qacct runtime by factor 7. For more entries the improvement will be higher.

   ------- Additional comments from roland Thu May 7 07:39:28 -0700 2009 -------
please ignore my last comment, it was for issue 2510

Change History (1)

comment:1 Changed 7 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed

Seems to be a duplicate of iz3024, fixed by [3200]

Note: See TracTickets for help on using tickets.