Opened 10 years ago

Closed 7 years ago

#662 closed defect (fixed)

IZ3000: default jmx installation fails for hosts not supporting java 1.5

Reported by: crei Owned by:
Priority: low Milestone:
Component: sge Version: 6.2u3
Severity: minor Keywords: install
Cc:

Description (last modified by admin)

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=3000]

        Issue #:      3000             Platform:     All      Reporter: crei (crei)
       Component:     gridengine          OS:        All
     Subcomponent:    install          Version:      6.2u3       CC:    None defined
        Status:       NEW              Priority:     P4
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    dom (dom)
      QA Contact:     dom
          URL:
       * Summary:     default jmx installation fails for hosts not supporting java 1.5
   Status whiteboard:
      Attachments:

     Issue 3000 blocks:
   Votes for issue 3000:


   Opened: Fri Apr 17 00:29:00 -0700 2009 
------------------------


During installation of qmaster the following messages appear:


Grid Engine JMX MBean server:
Detecting suitable JAVA ...
./inst_sge[125]: not0000: The specified number is not valid for this command.
./inst_sge[125]: not0000: The specified number is not valid for this command.
./inst_sge[125]: not0000: The specified number is not valid for this command.
./inst_sge[125]: Execute0000: The specified number is not valid for this command.
./inst_sge[125]: Execute0000: The specified number is not valid for this command.
./inst_sge[125]: Execute0000: The specified number is not valid for this command.
./inst_sge[125]: not0000: The specified number is not valid for this command.
./inst_sge[125]: not0000: The specified number is not valid for this command.
Please enter JAVA_HOME or press enter [] >>

Enter "/vol2/tools/SW/j2sdk1.4.2/hp11"
Warning: Cannot start jvm thread: Invalid java version (1.4.2.03)), we need 1.5.0 or higher

However this installation screen should mention that jdk 1.5 is needed for JMX:
===============================================================================

Grid Engine JMX MBean server
----------------------------

In order to use the SGE Inspect or the Service Domain Manager (SDM)
SGE adapter you need to configure a JMX server in qmaster. Qmaster
will then load a Java Virtual Machine through a shared library.

Do you want to enable the JMX MBean server (y/n) [y] >>

Change History (2)

comment:1 Changed 8 years ago by dlove

  • Resolution set to fixed

Fixed by LP-2009-10-27-2

comment:2 Changed 7 years ago by admin

  • Description modified (diff)
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.