Opened 10 years ago

Last modified 9 years ago

#688 new defect

IZ3067: on Windows, the display_win_gui features works only if enable_windomacc=true is set

Reported by: pollinger Owned by:
Priority: normal Milestone:
Component: sge Version: 6.0u8
Severity: Keywords: PC Windows execution
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=3067]

        Issue #:      3067             Platform:     PC             Reporter: pollinger (pollinger)
       Component:     gridengine          OS:        Windows 2000
     Subcomponent:    execution        Version:      6.0u8             CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    pollinger (pollinger)
      QA Contact:     pollinger
          URL:
       * Summary:     on Windows, the display_win_gui features works only if enable_windomacc=true is set
   Status whiteboard:
      Attachments:

     Issue 3067 blocks:
   Votes for issue 3067:


   Opened: Fri Jun 26 03:11:00 -0700 2009 
------------------------


If the SGE_Helper_Service.exe is installed on a Windows host and the load sensor reports "display_win_gui=true", a job requesting
"display_win_gui=true" can be scheduled to this host. But if the "execd_param enable_windomacc=false" is set (or it is not set at all), the
job will also be scheduled to this host. But then the sge_shepherd won't read the job users password from the sgepasswd file and will hand
over an empty password to the SGE_Helper_Service.exe. There, the LoginUser() call will fail then with the error message "Unkonwn user or
wrong password", even if the password was correctly registered with "sgepasswd".

Either the job shouldn't get scheduled to this host, or the host set be set into error state, because it has contradictory configurations.

Change History (0)

Note: See TracTickets for help on using tickets.