Opened 10 years ago

Closed 8 years ago

#690 closed enhancement (fixed)

IZ3072: gui jobs on windows vista only starting when there is a user logged into the system

Reported by: crei Owned by:
Priority: normal Milestone:
Component: sge Version: 6.2u3
Severity: minor Keywords: Windows execution
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=3072]

        Issue #:      3072             Platform:     All             Reporter: crei (crei)
       Component:     gridengine          OS:        Windows Vista
     Subcomponent:    execution        Version:      6.2u3              CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    pollinger (pollinger)
      QA Contact:     pollinger
          URL:
       * Summary:     gui jobs on windows vista only starting when there is a user logged into the system
   Status whiteboard:
      Attachments:

     Issue 3072 blocks:
   Votes for issue 3072:


   Opened: Wed Jul 1 01:07:00 -0700 2009 
------------------------


It is not possible to start a windows gui job on windows vista hosts without having a user logged in.

When a job is submitted to a vista host where no user is logged in the following error is logged into
the execd messages file:

06/30/2009 15:26:19|  main|host|E|06/30/2009 15:26:19 [1049715:3121]: Getting Logged On User Token failed: Only part of a ReadProcessMemory
or WriteProcessMemory request was completed. (errno=299)


The job was submitted with following command line:
> qsub -l h=host,display_win_gui=true -b yes -shell no /dev/fs/C/WINDOWS/notepad.exe
Your job 7 ("notepad.exe") has been submitted

The job goes into error state when he is dispatched to the host:
############################################################################
 - PENDING JOBS - PENDING JOBS - PENDING JOBS - PENDING JOBS - PENDING JOBS
############################################################################
      7 0.55500 notepad.ex cr114091     Eqw   06/30/2009 15:26:11     1

   ------- Additional comments from crei Wed Jul 1 01:11:58 -0700 2009 -------
Evaluation:

The vista job start code on the helper service differs from the standard implementation.
The problem is that the function GetInteractiveUserToken() can not get the a session token when no user is logged in.

How to Fix:
a) Find out how to startup GUI jobs when no user is logged into the vista host
b) Add a load report consumable which reports if it is possible to startup a windows GUI job on this host and
   request e.g. WGUISupport=true when a job is submitted.

Workaround:
A user must be logged into the windows vista system.
The GUI job also starts up correctly when the screen is logged.

Change History (1)

comment:1 Changed 8 years ago by dlove

  • Resolution set to fixed
  • Severity set to minor
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.