Opened 10 years ago

Closed 8 years ago

#716 closed defect (fixed)

IZ3132: Job validation behavour changed since 6.0 / 6.1

Reported by: ccaamad Owned by: Dave Love <d.love@…>
Priority: normal Milestone:
Component: sge Version: 6.2u3
Severity: Keywords: clients
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=3132]

        Issue #:      3132             Platform:     All      Reporter: ccaamad (ccaamad)
       Component:     gridengine          OS:        All
     Subcomponent:    clients          Version:      6.2u3       CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    DEFECT
                                   Target milestone: ---
      Assigned to:    roland (roland)
      QA Contact:     roland
          URL:
       * Summary:     Job validation behavour changed since 6.0 / 6.1
   Status whiteboard:
      Attachments:

     Issue 3132 blocks:
   Votes for issue 3132:


   Opened: Fri Sep 11 08:57:00 -0700 2009 
------------------------


I'm trying to migrate from 6.0 to 6.2u3 and discovered that job validation behaviour has changed: it rejects
jobs if queues are disabled!

e.g.

$ qsub -w e test.sh
Your job 162 ("serial.sh") has been submitted
$ qmod -d '*'
$ qsub -w e test.sh
Unable to run job: error: no suitable queues.
Exiting.

Also, reuti commented:

> I can only confirm this, and IMO it as a bug, as also submissions to
> calendar disabled queues are handled this way, hence -w e can't be
> used with calendars any longer when the queue is disabled right now.

Many thanks,

Mark

   ------- Additional comments from petrik Mon Oct 5 03:03:28 -0700 2009 -------
Issue will be resolved as part of 3138.

   ------- Additional comments from joga Mon Oct 12 06:49:46 -0700 2009 -------
*** Issue 3138 has been marked as a duplicate of this issue. ***

Change History (1)

comment:1 Changed 8 years ago by Dave Love <d.love@…>

  • Owner set to Dave Love <d.love@…>
  • Resolution set to fixed
  • Status changed from new to closed

In [3972/sge]:

(The changeset message doesn't reference this ticket)

Note: See TracTickets for help on using tickets.