Opened 16 years ago

Closed 6 years ago

#8 closed enhancement (fixed)

IZ97: exit code implications for various methods

Reported by: chaubal Owned by:
Priority: normal Milestone:
Component: sge Version: current
Severity: minor Keywords: man
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=97]

        Issue #:      97               Platform:     All           Reporter: chaubal (chaubal)
       Component:     gridengine          OS:        All
     Subcomponent:    man              Version:      current          CC:    None defined
        Status:       NEW              Priority:     P3
      Resolution:                     Issue type:    ENHANCEMENT
                                   Target milestone: ---
      Assigned to:    andreas (andreas)
      QA Contact:     ferstl
          URL:
       * Summary:     exit code implications for various methods
   Status whiteboard:
      Attachments:

     Issue 97 blocks:
   Votes for issue 97:


   Opened: Wed Nov 21 13:49:00 -0700 2001 
------------------------


What happens when various methods exit with different error codes is not
documented in one place.

Script/method           exit code       consequence
=====================================================================
job script              0               success
                        99              requeue
                        rest            "success", exit code in accounting file

prolog/epilog           0               success
                        99              requeue
                        rest            queue error state, job requeued

parallel start          0               success
                        rest            queue set to error state, job requeued

parallel stop           0               success
                        rest            queue set to error state, job not

requeued

suspend                 0               success
                        rest            success, no special meaning

restart                 0               success
                        rest            success, no special meaning

terminate               0               success
                        rest            success, no special meaning

migrate                 0               success
                        rest            success, for kernel ckpt special meaning: ckpt was not
sucessfull, did not happen (but migration will happen by SGE)

checkpoint              0               success
                        rest            success, for kernel ckpt special meaning: ckpt was not
sucessfull, did not happen

clean                   0               success
                        rest            success, no special meaning

   ------- Additional comments from chaubal Thu Nov 29 16:53:12 -0700 2001 -------
duplicate of issue # 106

*** This issue has been marked as a duplicate of 106 ***

   ------- Additional comments from chaubal Thu Nov 29 16:54:09 -0700 2001 -------
wrong issue closed

   ------- Additional comments from andreas Thu Oct 21 07:15:10 -0700 2004 -------
That's a man page issue at first.

Change History (3)

comment:1 Changed 7 years ago by dlove

  • Resolution set to duplicate
  • Severity set to minor
  • Status changed from new to closed

Duplicate of #9.

comment:2 Changed 7 years ago by dlove

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not sure this is a duplicate

comment:3 Changed 6 years ago by dlove

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.