Opened 10 years ago

Closed 7 years ago

#867 closed enhancement (duplicate)

IZ245: Need a naming convention for all resource bundles

Reported by: rhierlmeier Owned by:
Priority: high Milestone:
Component: hedeby Version: current
Severity: minor Keywords: Sun util
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=245]

        Issue #:      245          Platform:     Sun           Reporter: rhierlmeier (rhierlmeier)
       Component:     hedeby          OS:        All
     Subcomponent:    util         Version:      current          CC:    None defined
        Status:       NEW          Priority:     P2
      Resolution:                 Issue type:    ENHANCEMENT
                               Target milestone: 1.0u5next
      Assigned to:    marcingoldyn (marcingoldyn)
      QA Contact:     rhierlmeier
          URL:
       * Summary:     Need a naming convention for all resource bundles
   Status whiteboard:
      Attachments:


     Issue 245 blocks:
   Votes for issue 245:     Vote for this issue


   Opened: Thu Nov 29 02:33:00 -0700 2007 
------------------------


   We have a lot of "dead" messages in our resource bundles. We need a testsuite
   test (or an ant task) which finds unused messages.
               ------- Additional comments from crei Mon Dec 3 01:56:57 -0700 2007 -------
   already submitted

   *** This issue has been marked as a duplicate of 208 ***
               ------- Additional comments from rhierlmeier Wed Feb 27 06:42:59 -0700 2008 -------
   With the fix of this issue we should cleanup the resource bundles.

   We need a naming convention for all resource bundles. We suggest that the
   name of the resource bundle is the name of the package without com.sun.grid.grm.

   We have to check what naming conventions the resource bundles have. May be dots
   are not allowed in it.

   service-impl.properties -> resource bundle for package com.sun.grid.grm.service.
               ------- Additional comments from rhierlmeier Thu Feb 28 02:47:26 -0700 2008 -------
   Reassigned
               ------- Additional comments from rhierlmeier Thu Feb 28 03:24:37 -0700 2008 -------
   It's now a task
               ------- Additional comments from crei Wed Aug 6 05:03:07 -0700 2008 -------
   Dead message detections filed as testsuite issue #220

   Still a hedeby task is the resource bundle naming convention task
               ------- Additional comments from crei Wed Aug 6 05:05:08 -0700 2008 -------
   Renamed Issue summary and changed subcomponent - issue is no testsuite issue
               ------- Additional comments from rhierlmeier Wed Aug 6 06:50:53 -0700 2008 -------
   It's a cleanup issue for future releases (ENHANCEMENT).
   Should be in the subcomponents infrastructure.
               ------- Additional comments from rhierlmeier Wed Nov 25 07:21:10 -0700 2009 -------
   Milestone changed

Change History (1)

comment:1 Changed 7 years ago by dlove

  • Resolution set to duplicate
  • Severity set to minor
  • Status changed from new to closed

Duplicate of #865

Note: See TracTickets for help on using tickets.