Opened 13 years ago

Last modified 9 years ago

#945 new enhancement

IZ4: need host parameter "xterm"

Reported by: joga Owned by:
Priority: normal Milestone:
Component: testsuite Version: current
Severity: Keywords: framework
Cc:

Description

[Imported from gridengine issuezilla http://gridengine.sunsource.net/issues/show_bug.cgi?id=4]

        Issue #:      4               Platform:     All           Reporter: joga (joga)
       Component:     testsuite          OS:        All
     Subcomponent:    framework       Version:      current          CC:    None defined
        Status:       RESOLVED        Priority:     P3
      Resolution:     FIXED          Issue type:    ENHANCEMENT
                                  Target milestone: milestone 1
      Assigned to:    issues@testsuite
      QA Contact:     joga
          URL:
       * Summary:     need host parameter "xterm"
   Status whiteboard:
      Attachments:

     Issue 4 blocks:
   Votes for issue 4:     Vote for this issue


   Opened: Wed Oct 25 00:10:00 -0700 2006 
------------------------


We need a host specific setting "xterm" as we already have with ssh, gnuplot,
tar etc.

The master_debug and schedd_debug modes have to use resolve_binary to read the
configured value for xterm instead of a hard coded path.

   ------- Additional comments from joga Wed Oct 25 00:11:02 -0700 2006 -------
This was IZ 1698 in project gridengine.

   ------- Additional comments from joga Wed Oct 25 00:11:53 -0700 2006 -------
An alternative might be to get the xterm from arch_variables, as is done during
the installation of execution hosts by the install scripts.

   ------- Additional comments from crei Thu Jul 2 01:47:38 -0700 2009 -------
The correct way to get the xterm binary path is to use the procedure
get_binary_path:

e.g. set config_xterm_path [get_binary_path $host "xterm"]

Change History (0)

Note: See TracTickets for help on using tickets.